Ganglia unable to show stats for selected date range

RESOLVED INCOMPLETE

Status

Infrastructure & Operations
Infrastructure: Other
RESOLVED INCOMPLETE
4 years ago
3 years ago

People

(Reporter: harsha, Assigned: rbryce)

Tracking

Details

(Reporter)

Description

4 years ago
Hi Rick,
      We are having trouble in seeing previous days stats for our bagheera cluster.
http://ganglia1.metrics.scl3.mozilla.com/ganglia/?r=hour&cs=08%2F19%2F2013+00%3A00+&ce=08%2F19%2F2013+00%3A00+&c=scl3_prd_cluster06&h=node1.bagheera.metrics.scl3.mozilla.com&tab=m&vn=&mc=2&z=small&metric_group=ALLGROUPS

The above url should show the stats for Aug 18th to Aug 19th but it shows the current data.

Thanks,
Harsha
(Reporter)

Updated

4 years ago
Group: mozilla-corporation-confidential
(Assignee)

Updated

4 years ago
Assignee: infra → rbryce
Group: mozilla-corporation-confidential
(Reporter)

Comment 1

4 years ago
Just to add the bug, previous url works as expected but when we click one of the graphs from the summary page it will show the current data rather than the dates given.
http://ganglia1.metrics.scl3.mozilla.com/ganglia/graph_all_periods.php?c=scl3_prd_cluster06&h=node1.bagheera.metrics.scl3.mozilla.com&v=70380739&m=bagheera.consumer.telemetry.consumed.count&r=custom&z=small&jr=&js=&st=1377201466&cs=08%2F19%2F2013%2000%3A00%20&ce=08%2F19%2F2013%2000%3A00%20&vl=messages&z=large

above url has cs & ce params but showing the current data
(Assignee)

Comment 2

4 years ago
(In reply to Harsha [:harsha] from comment #1)
> Just to add the bug, previous url works as expected but when we click one of
> the graphs from the summary page it will show the current data rather than
> the dates given.
> http://ganglia1.metrics.scl3.mozilla.com/ganglia/graph_all_periods.
> php?c=scl3_prd_cluster06&h=node1.bagheera.metrics.scl3.mozilla.
> com&v=70380739&m=bagheera.consumer.telemetry.consumed.
> count&r=custom&z=small&jr=&js=&st=1377201466&cs=08%2F19%2F2013%2000%3A00%20&c
> e=08%2F19%2F2013%2000%3A00%20&vl=messages&z=large
> 
> above url has cs & ce params but showing the current data

Harsha - 

I can certainly recreate this issue, just having difficulty identifying the cause.
With no errors being reported in the logs, my hunch is a configuration issue on the server side.
(Assignee)

Comment 3

4 years ago
The ganglia-web interface may be suffering from a bug related to this very action.  Versions of ganglia released within the last year fix an issue with the CE and CS parameters get ignored..  I hate to say that an upgrade will fix this issue, as I am not certain of that.
(Assignee)

Comment 4

4 years ago
Ganglia going is being decommissioned, closing incomplete.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
Component: Infrastructure: Monitoring → Infrastructure: Other
Product: Infrastructure & Operations → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.