Closed Bug 908479 Opened 6 years ago Closed 6 years ago

[B2G] [Buri] [1.2] [Browser] Pages snap back to the top when attempting to scroll the page

Categories

(Core :: Graphics: Layers, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 907977
blocking-b2g koi+

People

(Reporter: ckreinbring, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

Description:
Attempting to scroll a browser page will cause the page to snap back to the top when the user continues the scrolling.

Repro Steps:
1) Update Buri to Build ID: 20130822040202
2) Launch the Browser and navigate to a site like youtube.com or yahoo.com (the longer the destination page, the better).
3) Once the page loads, attempt to scroll down and observe the page's reaction.

Actual:
After scrolling the page once, it will snap back to the top if the user attempts to scroll the page further. 

Expected:
The page can scroll up and down without snapping to other locations when another scrolling attempt is made.

Environmental Variables
Build ID: 20130822040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/2ab07dec6404
Gaia: abd81ff5e49bf0c9479cdc5c5eb6975cc776f632
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
See attached logcat logs
request escalation due to high impact of browser to end-user
blocking-b2g: --- → koi?
This sounds like a regression from the work kats has been doing in the APZC arena.
Component: Gaia::Browser → Graphics: Layers
Product: Boot2Gecko → Core
Version: unspecified → Trunk
No longer blocks: b2g-central-dogfood
Keywords: smoketest
Yeah, sorry. This is a regression from bug 898443 will be fixed by bug 907977.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 907977
blocking-b2g: koi? → koi+
You need to log in before you can comment on or make changes to this bug.