Text selection: Double tapping on a word should select it.

RESOLVED DUPLICATE of bug 921965

Status

Firefox OS
Gaia::Keyboard
P1
normal
RESOLVED DUPLICATE of bug 921965
4 years ago
4 years ago

People

(Reporter: Stephany Wilkes, Assigned: janjongboom)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ux-tracking)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 794329 [details]
See page 20 for spec on double tapping a word for text selection.

See the recommendation on page 20 of the attached spec.
Blocks: 921965
(Reporter)

Updated

4 years ago
Blocks: 924662

Updated

4 years ago
Blocks: 924419
(Assignee)

Updated

4 years ago
Assignee: nobody → janjongboom
(Assignee)

Updated

4 years ago
Depends on: 921964
Stephany, double tapping interferes with double tap to zoom in / out on certain areas of the web page. Are we sure we want to use this gesture?
Flags: needinfo?(swilkes)
(Reporter)

Comment 2

4 years ago
Wait a moment, please. Text selection is not in scope for 1.3, and the Keyboard specs were updated extensively over the course of 1.3, with Bruce's team. This work should NOT be in progress right now. What is going on, please?
Not much, I was just going through relevant bugs because I have the selection bugs on my name.
(Reporter)

Comment 4

4 years ago
Got it. Please work with Carrie Wang, who is UX on Keyboard and will be working off of Bruce Huang's Keyboard backlog for 1.4. In the meantime, I'll flag Bruce to see if this will make it into the 1.4 backlog.
Flags: needinfo?(swilkes) → needinfo?(bhuang)
If we have cursor movement in scope for 1.4 I think we should add this as well, as it's trivial.
Flagging Carrie in.  We should consider it as part of text selection, not cursor movement, correct?  Depending on how much work it is, however, I would prioritize it lower than other work such as text selection on non-editable text.
Flags: needinfo?(bhuang) → needinfo?(cawang)
Yes, but they're very much correlated.
Yes, the double-tap behavior will definitely conflict with zoom in/out. 
We're currently working on the spec and we'd suggest applying long-press to select words.
In addition, agree with Bruce, this should be a part of text selection not cursor movement.

Thanks!
Flags: needinfo?(cawang)

Updated

4 years ago
No longer blocks: 921965

Comment 9

4 years ago
We are now using bug 921965 for tracking the text selection implementation in v2.0. Close this as duplicated bug. The new US specification is also in the bug 921965.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 921965
You need to log in before you can comment on or make changes to this bug.