zffos1.1 There is no low battery warning.

RESOLVED WONTFIX

Status

Firefox OS
General
RESOLVED WONTFIX
5 years ago
2 months ago

People

(Reporter: ji.chen5, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; CIBA; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; InfoPath.2; .NET4.0C; .NET4.0E; .NET CLR 3.5.30729; TCO_20130823084927)
(Reporter)

Updated

5 years ago
Blocks: 899451

Updated

5 years ago
Keywords: qawanted

Comment 1

5 years ago
Hi Chen,

This one seems to be duplicated to 909174. Please help to check.
Flags: needinfo?(ji.chen5)

Updated

5 years ago
Duplicate of this bug: 909174

Comment 3

5 years ago
I am unable to repro this issue on these two builds:

Environmental Variables
Device: Unagi 1.1.0
Build ID: 20130830041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/2fb19341d934
Gaia: 577ab5105af418efc8ded00798fd3644b3dac674
Platform Version: 18.1

Environmental Variables
Device: Unagi 1.2.0.0
Build ID: 20130830162255
Gecko: http://hg.mozilla.org/mozilla-central/rev/cfe8b0ab6d59
Gaia: 46dcd65c2075f0872a4597169ad9c9f7bdba0335
Platform Version: 26.0a1

I ran youtube videos until the battery was reduced to 10% and at that percent a prompt/warning appeared for low battery.
Let me know if you need any other information.

Updated

5 years ago
Keywords: qawanted
QA Contact: gbennett
Does this reproduce on a ZTE 1.1 partner build?
Keywords: qawanted

Comment 5

5 years ago
Does not repro on ZTE 1.1 partner build.

Environmental Variables
Device: ZTE 1.1.0.0
Build ID: 20130820074633
Gecko: /rev/
Gaia: a05916a393e9ea4e0b532eec90ce6f076e5454a5
Platform Version: 18.1

Used the same repro steps as prior charging the phone to ~20% and bringing it down to 10% with apps running in the background along with playing youtube. Warning showed correctly at 10%. At what screen was this issue first seen?
Keywords: qawanted

Updated

5 years ago
Whiteboard: [closeme 9/10/2013]
(Reporter)

Comment 6

5 years ago
Hi  gbennett:

  I have test the bug with the newest version, and it can be reproduced.
  
  I ran videos when baterry remains 30%.When it drop to 9%, there is still no waring for low baterry.  

  We want to see how it processes the event reported from the buttom for the message of low baterry.Could you please tell me which file we could refer to?
Flags: needinfo?(ji.chen5)
This is not a blocker for certification in V1.1 but I also think this feature should be implemented in feature versions.

Please consider it for V1.2 --> nominating for koi?
blocking-b2g: --- → koi?
Juan

Feature landing is not allowed unless it is mandatory. Please confirm if this is actually needed.
Flags: needinfo?(jbecerra)
I think you meant to flag Juan in comment 7.
Flags: needinfo?(jbecerra) → needinfo?(juan.perezbedmar)

Comment 10

5 years ago
(In reply to ji.chen5 from comment #6)
> Hi  gbennett:
> 
>   I have test the bug with the newest version, and it can be reproduced.
>   
>   I ran videos when baterry remains 30%.When it drop to 9%, there is still
> no waring for low baterry.  
> 
>   We want to see how it processes the event reported from the buttom for the
> message of low baterry.Could you please tell me which file we could refer to?

I do not know which file you can refer to. Sorry mate.
(In reply to Preeti Raghunath(:Preeti) from comment #8)
> Juan
> 
> Feature landing is not allowed unless it is mandatory. Please confirm if
> this is actually needed.

I think we can probably live without this in V1.2. but I will suggest the UX team to consider implementing some kind of pop-up warnings or similar when battery is low for V1.3.

By the time V1.3 will be in the market in commercial devices, we expect to have attracted a lot of new-comers, including some former Android users. This will probably cause that the number of users with a more strict perception of what the "expected behaviour" should be under certain situations (such as this low-battery situation) will increase.

Rafa, what do you think?
blocking-b2g: koi? → 1.3?
Flags: needinfo?(juan.perezbedmar) → needinfo?(hello)

Comment 12

5 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(hello)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 9/10/2013]
Sorry, but I still haven't got feedback from UX team, and I really think this feature should be included in v1.3.

Ivan, could you please help me to reach the proper person/people in UX team to discuss about this feature request? Thanks!
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(itsay)
Resolution: INCOMPLETE → ---
Hi, 

I think to have this feature would be really useful. Users generally assume this to be present on commercial devices, as it is in the other platforms. 

Could we include this at least for 1.3?

adding Rafa to ni. 

Thanks, 
David
Flags: needinfo?(hello)

Comment 15

5 years ago
(In reply to Juan Perez-Bedmar [:juanpbf]  -  Good bye summer! from comment #13)
> Sorry, but I still haven't got feedback from UX team, and I really think
> this feature should be included in v1.3.
> 
> Ivan, could you please help me to reach the proper person/people in UX team
> to discuss about this feature request? Thanks!

Hi UX folks,

Would you please take a look this requirement which is suggested by partner to be included in v1.3.

Ivan Tsay
Flags: needinfo?(itsay) → needinfo?(firefoxos-ux-bugzilla)

Comment 16

5 years ago
UX was first flagged yesterday (thank you, Ivan). I am flagging Rob and Francis, who are UX for Systems Front-end for 1.3, and Peter so he can follow this for possible backlog inclusion for that team.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(pdolanjski)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(fdjabri)
(In reply to gbennett from comment #3)
> I ran youtube videos until the battery was reduced to 10% and at that
> percent a prompt/warning appeared for low battery.

I'm slightly confused by the contradictory comments on this bug.  The testing in comment #3 indicate that there is a warning for low battery (unless this refers to the Power Save mode), but other comments say there is no warning.

Admittedly, the implementation of this (if it exists) was before my time, so I'm not sure exactly what is in place today.
  
Do low battery notifications exist?  
If so, are they not working in the vendor build?  
If not, why does comment 3 mention seeing them.
Flags: needinfo?(pdolanjski)
(In reply to Peter Dolanjski [:pdol] from comment #17)
> (In reply to gbennett from comment #3)
> > I ran youtube videos until the battery was reduced to 10% and at that
> > percent a prompt/warning appeared for low battery.
> 
> I'm slightly confused by the contradictory comments on this bug.  The
> testing in comment #3 indicate that there is a warning for low battery
> (unless this refers to the Power Save mode), but other comments say there is
> no warning.

I'm also a bit confused here. Comment #3 and Comment #5 makes reference to Youtube, but not to other situations, so even if those comments are correct, this would still be a bug IMHO.
Anyway, I've been trying to see any notification by watching YouTube videos over and over, and once the battery decreases under 10%, the only sign of low battery is the icon itself going red, but no pop-up is shown. 

I'm using a V1.1 commercial build:
QC RIL version:
"ro.build.firmware_revision=01.01.00.019.215"
gaia commit:
4584c40 rm long short
gecko commit:
8ae9e11 tengfei add eng code with 87274

needinfo to gbennett@qanalydocs.com for clarification on his comments
Flags: needinfo?(gbennett)

Comment 19

5 years ago
To answer Peter's question "Do low battery notifications exist?" in comment #17, yes. On the current build, I see a "Battery almost empty" notification at the top, with a little red battery image, when the battery appears to have about < 5% left.

Comment 20

5 years ago
(In reply to Juan Perez-Bedmar [:juanpbf] @Madrid from comment #18)
> (In reply to Peter Dolanjski [:pdol] from comment #17)
> > (In reply to gbennett from comment #3)
> > > I ran youtube videos until the battery was reduced to 10% and at that
> > > percent a prompt/warning appeared for low battery.
> > 
> > I'm slightly confused by the contradictory comments on this bug.  The
> > testing in comment #3 indicate that there is a warning for low battery
> > (unless this refers to the Power Save mode), but other comments say there is
> > no warning.
> 
> I'm also a bit confused here. Comment #3 and Comment #5 makes reference to
> Youtube, but not to other situations, so even if those comments are correct,
> this would still be a bug IMHO.
> Anyway, I've been trying to see any notification by watching YouTube videos
> over and over, and once the battery decreases under 10%, the only sign of
> low battery is the icon itself going red, but no pop-up is shown. 
> 
> I'm using a V1.1 commercial build:
> QC RIL version:
> "ro.build.firmware_revision=01.01.00.019.215"
> gaia commit:
> 4584c40 rm long short
> gecko commit:
> 8ae9e11 tengfei add eng code with 87274
> 
> needinfo to gbennett@qanalydocs.com for clarification on his comments

Hello Juan, what information would you like specifically?
(In reply to gbennett from comment #20)
> 
> Hello Juan, what information would you like specifically?

Hi, my main doubts are:
- Have you seen the prompt/warning in any other situation, or it happens only with YouTube?
- Are the builds you are using based on commercial (Qualcomm's) RIL or Mozilla's RIL?

And if you happen to have a screenshot of the low battery prompt, that would be wonderful.

Thanks in advance
Marco had the following to say:
"Please refer to the link as below where tried to display a overlay toast for battery notification.
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/battery_manager.js#L121
And the level is 10%.
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/battery_manager.js#L12

I am not sure whether the issue is related to display between full screen (video playing) and a overlay toast.
This may need the confirm from gaia developers."

Marco, do you know which gaia developer would know this?
Flags: needinfo?(mchen)

Comment 23

5 years ago
Created attachment 821325 [details]
BatteryLowMessage.png

(In reply to Juan Perez-Bedmar [:juanpbf] @Madrid from comment #21)
> Hi, my main doubts are:
> - Have you seen the prompt/warning in any other situation, or it happens
> only with YouTube?
> - Are the builds you are using based on commercial (Qualcomm's) RIL or
> Mozilla's RIL?
> 
> And if you happen to have a screenshot of the low battery prompt, that would
> be wonderful.
> 
> Thanks in advance


The battery warning notification appeared while in the settings app using a mozRIL build and on the homescreen as well once the battery dropped below 10%. Heads up reproing this issue without using some sort of streaming service can take a while and if you get stuck at 11%, plug then unplug the device from a computer and the battery % should update quicker. Let me know if you need any other info.
Flags: needinfo?(gbennett)

Comment 24

5 years ago
(In reply to Peter Dolanjski [:pdol] from comment #22)
> Marco had the following to say:
> Marco, do you know which gaia developer would know this?

Hi Alive,

Could you take a look to this issue? It's about the low battery prompt didn't be shown during video playing.

Thanks.
Flags: needinfo?(mchen) → needinfo?(alive)
Does this only happens when video is playing? Do you mean built-in video app or youtube.com or vidoe on web page or something else?
Flags: needinfo?(alive)
The low battery indicator should be shown in the following circumstances:

1) Battery banner should be shown if the battery level drops beneath a certain threshold (10% for battery almost empty). 

2) Battery banner should be shown if the user wakes up the screen or boots up the device and the battery has dropped below a certain threshold. Battery banner should only be shown once after the threshold is passed - not every time the screen wakes up or the device boots up.

3) Battery banner should be shown if the device charger is disconnected and the battery charge is beneath a certain threshold.
Flags: needinfo?(fdjabri)
Flags: needinfo?(rmacdonald)
This isn't a committed feature for 1.3, so this isn't going to block 1.3. Clearing nom.
blocking-b2g: 1.3? → ---

Comment 28

2 months ago
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.