[B2G][Helix][Setting][Sound][shijinde]select a ring and preview, enter the home key, the ring is playing always

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
P2
critical
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: lecky, Assigned: Evelyn Hung)

Tracking

unspecified

Firefox Tracking Flags

(b2g18 affected, b2g-v1.1hd affected, b2g-v1.2 unaffected)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E; Zune 4.7; Tablet PC 2.0)

Steps to reproduce:

1、go to setting screen, select sound, and then select tones.
2、select the first ring which names ringer_classic.....
3、enter home key


Actual results:

1、the ring is playing.


Expected results:

1、the ring will stop when go to home screen
(Reporter)

Updated

5 years ago
Severity: normal → critical
Priority: -- → P2
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?
(Assignee)

Comment 1

5 years ago
In this case, the example ringtone is a big file, and it can keep playing for 30sec. It seems the audio channel is mixed-up.

Arthur, can you help on identifying the root cause? This is terrible on partner's build since the long ringtone is customized to the default one.
Flags: needinfo?(arthur.chen)
(Assignee)

Comment 2

5 years ago
bug 909275 might be a dup.
I think we should stop playing the previewing sound when leaving the settings app.
Flags: needinfo?(arthur.chen)
(Reporter)

Comment 4

5 years ago
Hi, what is the result about this problem? 

if you can't resolve in v1.1, please give me the information in the bug.

or if you can resolve in v1.1, also please give me the plan.

Thanks
(Assignee)

Comment 5

5 years ago
I think we will fix this problem on master first. Arthur, can you fix it or mentor someone to fix it? Thanks.
Flags: needinfo?(arthur.chen)
(Reporter)

Comment 6

5 years ago
Hi, when do you will resolve the problem?
Assignee: nobody → arthur.chen
Flags: needinfo?(arthur.chen)
I can reproduce this bug with the hd branch but not master.
This is reproduced on other v1.1 devices as well (tested on buri). We will not block hd specifically on 1.1 generic functional bugs.

bumping to leo?
blocking-b2g: hd? → leo?
if not needed in hd as well, moving to koi?
blocking-b2g: leo? → koi?
Only reproducible on v1.1, not blocking koi.
Status: UNCONFIRMED → NEW
blocking-b2g: koi? → leo?
status-b2g18: --- → affected
status-b2g-v1.1hd: --- → affected
status-b2g-v1.2: --- → unaffected
Ever confirmed: true
Thanks Tim, so I'm moving it to hd.
blocking-b2g: leo? → hd?
With above comments, we'll not block this specifically for v1.1HD, and will not block this for v1.1 either.
The behaviour is consistent across v1.1 devices.
blocking-b2g: hd? → ---
(Reporter)

Updated

4 years ago
Flags: needinfo?(brg)
Agree with Wayne in comment 12. Happy to know that it is improved from v1.2+  :-)
Flags: needinfo?(brg)
(Assignee)

Comment 14

4 years ago
Created attachment 8337521 [details]
stop audio preview when user clicks home button

just a quick bandage for v1.1 per partner's request. The real problem has been fixed in later release.
(Assignee)

Updated

4 years ago
Attachment #8337521 - Attachment is patch: false
(Assignee)

Updated

4 years ago
Attachment #8337521 - Attachment is obsolete: true
(Assignee)

Comment 15

4 years ago
Created attachment 8337524 [details] [review]
stop audio preview when user clicks home button

Just a quick bandage for v1.1 per partner's request. The real problem has been fixed in later release.
(Assignee)

Updated

4 years ago
Attachment #8337524 - Flags: review?(arthur.chen)
(Assignee)

Updated

4 years ago
Assignee: arthur.chen → ehung
Created attachment 8337550 [details] [review]
Workaround Patch: https://github.com/mozilla-b2g/gaia/pull/13995

Here is a workaround patch. It stops the audio preview when exiting the settings app.

Although this patch doesn't fix the root cause, I propose merging it into v1.1.0hd branch since this issue doesn't appear on v1.2 and we do need a workaround here.
Comment on attachment 8337524 [details] [review]
stop audio preview when user clicks home button

r=me. Thanks!
Attachment #8337524 - Flags: review?(arthur.chen) → review+
(Assignee)

Comment 18

4 years ago
Guess this bug has been fixed on vendor side. close it as wontfix because the r+ patch here wasn't landed to v1.1hd branch.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.