[B2G][Helix][Setting][Sound][shijinde]Sumbit the done and go back to sound screen is very slowly

RESOLVED WONTFIX

Status

P3
critical
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: lecky.wanglei, Assigned: arthurcc)

Tracking

({perf})

unspecified

Firefox Tracking Flags

(b2g18 affected, b2g-v1.1hd affected, b2g-v1.2 unaffected)

Details

(Whiteboard: [c= p= s=2013.10.25 u=])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 794529 [details]
WP_20130818_002.jpg

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E; Zune 4.7; Tablet PC 2.0)

Steps to reproduce:

1、go to setting screen, select sound
2、select change in tones
3、select the one ring
4、enter done button


Actual results:

1、go back to sound screen is very very slowly. you can see two screen together.


Expected results:

1、go back quickly, and never see two screen together
(Reporter)

Updated

5 years ago
Severity: normal → critical
Priority: -- → P2
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?
Could you post more information about what version of B2G you are seeing this in?  Please, go into Settings App, select "Device Information" and post what version is under "Software".
Severity: critical → normal
Flags: needinfo?(lecky.wanglei)
Keywords: perf
Priority: P2 → --
Whiteboard: [c= s= p=]
(Reporter)

Comment 2

5 years ago
the software is Boot2Gecko 1.1.0hd-prerelease.

Today, I had told with Evenly about this problem, maybe when I select the ring, and done, I found the code will store the music file, if the music file is larger, so make the problem.

you can analyce the code in sound.js.
Flags: needinfo?(lecky.wanglei)
(Reporter)

Updated

5 years ago
Severity: normal → critical
Priority: -- → P1
(Reporter)

Comment 3

5 years ago
Hi, what is the result about this problem? 

if you can't resolve in v1.1, please give me the information in the bug.

or if you can resolve in v1.1, also please give me the plan.

Thanks

Comment 4

5 years ago
I can't reproduce it on the latest partner build (9/10). Could you please check it again?
(Reporter)

Comment 5

5 years ago
Do you use huawei phone? or your phone? 

Do you modify something?

Thanks
(Reporter)

Comment 6

5 years ago
Hi, I can reproduce this problem every time by using a large ring file.

and I had sent to you by email.

Other, If you enter done or back button in charge ring screen, the charge screen is very slowly.

it maybe need two seconds or more to go to sound screen.

so please also attent these problems.

Thanks

Comment 7

5 years ago
Yes, we can reproduce it now. It seems writing a big file into settings database blocks CSS transition on main thread.

Arthur, I've sent you the test file, please help on this issue. Thanks.
Assignee: nobody → arthur.chen
(Reporter)

Comment 8

5 years ago
Hi, when do you will resolve the problem?
In the master bracnh, pick is implemented using an inline activity. The transition problem is no longer reproduced.
Arthur, it seems that this is a generic v1.1 phenomenon, so I am bumping this to leo?

We're not blocking any functional bug specifically for HD unless it's device specific.
blocking-b2g: hd? → leo?
if not blocked for hd, lets move to koi?
blocking-b2g: leo? → koi?
This is a v1.1 only bug. Not blocking koi.
Status: UNCONFIRMED → NEW
blocking-b2g: koi? → leo?
status-b2g18: --- → affected
status-b2g-v1.1hd: --- → affected
status-b2g-v1.2: --- → unaffected
Ever confirmed: true
Preeti,

We're using the HD flag only for device specific or resolution related bugs, we're nominating this bug for leo? as it impacts all leo branches (considering there are partners still picking up this branch for their upcomign updates).

If leo triage decides this is not critical enough to block, we can minus it and declare not fixing on all v1.1 releases, as comment 12 suggest this bug is not valid for v1.2 maybe we should wontfix this for 1.1?
(Reporter)

Updated

5 years ago
Priority: P1 → P3
got it.
(Reporter)

Updated

5 years ago
Flags: needinfo?(brg)
Reporter had modified priority to P3. IMHO we should mark it as WONTFIX for 1.1.
Flags: needinfo?(brg)
As this is a generic problem of v1.1 and per comment 15. Mark it as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
blocking-b2g: leo? → ---

Updated

5 years ago
Whiteboard: [c= s= p=] → [c= p= s=2013.10.25 u=]
You need to log in before you can comment on or make changes to this bug.