Closed Bug 908614 Opened 8 years ago Closed 8 years ago

Emergency calls must be done when device is not registered(no SIM card inserted)

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86
macOS
defect
Not set
normal

Tracking

(blocking-b2g:koi+)

RESOLVED DUPLICATE of bug 904625
blocking-b2g koi+

People

(Reporter: brg, Assigned: rexboy)

References

Details

Attachments

(4 files)

First of all, I open the bug in the gaia part but I dont know if it is from gecko or gaia.

STR: No SIM card, dial 112, press green key.

Issue: the device whithout SIM card does not perform emergency calls. It popus a message saying that to make a voice call, the device should be registered, which is true for normal calls but not for emergency calls.

This behaviour was fine in v1-train(voice call to emergency number is performed) but wrong in master( voice call to emergency number is not made).

Working fine in Unagi v1-train: Gecko-963b062.Gaia-f7d6c5f
Not working in Unagi master: 8dfeba9.Gaia-e0cde65

Adding logcats of both testing scenarios
Nominating to koi since this is a regulatory blocking issue for Spain market.
blocking-b2g: --- → koi?
Before bug 903257, voice.network isn't a null object while its properties are null. However, bug 903257 set voice.network to null when the voice network isn't registered that makes the condition [1] is always hit. And actually, we shouldn't check |network| in [1] because it's allowed to call dialEmergency() even there's no network.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/telephony_helper.js#L12
blocking-b2g: koi? → koi+
Assignee: nobody → rexboy
Blocks: 890825
Bug 904625 fixed this issue with the same way as my comment 5.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 904625
You need to log in before you can comment on or make changes to this bug.