CSS-animated SVG is not animated anymore as background-image, regression

RESOLVED DUPLICATE of bug 1190881

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 1190881
5 years ago
2 years ago

People

(Reporter: Stanislas Signoud, Assigned: u459114)

Tracking

(Blocks: 1 bug, {regression})

24 Branch
x86_64
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox23 unaffected, firefox24 disabled, firefox25 disabled, firefox26 affected, firefox33 affected, firefox34 affected, firefox35 affected, firefox36 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 794624 [details]
Example: animated spinner.svg

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130817191046

Steps to reproduce:

We replaced our GIF spinners with SVG animated ones, using embedded CSS animation; they are rendered using background-image.

1. Create an animated SVG file
2. Save it an asset (spinner.svg, here)
3. Link it in a CSS file as a background-image

JSFiddle: http://jsfiddle.net/zBudu/ (SVG file is attached)


Actual results:

Since Firefox Aurora (Gecko 25), only the first animation frame is rendered. 


Expected results:

In Firefox Stable (and in Chrome Stable), all frames are correctly rendered and animation occured.
(Reporter)

Comment 1

5 years ago
Please note that it doesn't happen with Firefox 23 but with Firefox 25:

User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0

Comment 2

5 years ago
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/243533ca7769
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130524 Firefox/24.0 ID:20130524211144
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d1b9087dd689
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130525 Firefox/24.0 ID:20130525045945
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=243533ca7769&tochange=d1b9087dd689
Regressed by: 
  297eccee61b5 Jonathan Watt — Bug 854765 - Get rid of the DidSetStyleContext overrides in SVG frame code to avoid some major perf hits. r=roc
Blocks: 854765
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
status-firefox23: --- → unaffected
status-firefox24: --- → affected
status-firefox25: --- → affected
status-firefox26: --- → affected
Component: Layout: Images → SVG
Keywords: regression
OS: Linux → All
Resolution: --- → DUPLICATE
Version: 23 Branch → 24 Branch
Duplicate of bug: 907503
As pointed out in bug 907503 comment 49, this bug's original testcase ( http://jsfiddle.net/zBudu/ ) is not fixed, so let's un-dupe & reopen this bug.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Updated

4 years ago
status-firefox24: affected → disabled
status-firefox25: affected → disabled
status-firefox33: --- → affected
status-firefox34: --- → affected
status-firefox35: --- → affected
status-firefox36: --- → affected

Updated

4 years ago
Flags: needinfo?(jwatt)
I believe this was fixed by longsonr's patch in bug 1067375. Robert?
Flags: needinfo?(jwatt)
Doesn't look like it. That bug is fixed in Nightly (I verified w/ its testcase), whereas this bug still affects Nightly.
No it's not fixed by anything I've landed yet. I think it might be fixed by bug 975757 though depending on how that turns out.
bug 975757 won't fix this. Presumably some style changes need an nsSVGEffects:InvalidateRenderingObservers to be called. bug 975757 will add a change hint for this.
Comment hidden (obsolete)
Depends on: 975757
Duplicate of this bug: 1121478

Updated

3 years ago
Blocks: 1121478

Comment 10

3 years ago
Would it be possible to re-evaluate the priority of this bug? I just discovered this when preparing a demo for the SVGWG. Blink recently announced an intent to move away from SMIL in favor of CSS animations for svg-in-image. If it pans out (even best-case this wouldn't land for several months), this leaves developers in a tough spot:
Blink/Edge/WebKit would support CSS animations in SVG images.
Gecko/WebKit would support SMIL animations in SVG images.

Updated

2 years ago
Blocks: 1262352
Comment hidden (me-too)
Comment hidden (me-too)
(Assignee)

Updated

2 years ago
See Also: → bug 1190881
(Assignee)

Comment 13

2 years ago
The root cause of this bug is the same with bug 1190881.
We did not give any nsDOMNavigationTiming to the SVGDocument inside SVGDocumentWrapper.
I will dup this one after fix bug 1190881
(Assignee)

Updated

2 years ago
Assignee: nobody → cku
(Assignee)

Updated

2 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1190881
You need to log in before you can comment on or make changes to this bug.