500 error when a user changes his email to a one that already exists.

VERIFIED FIXED

Status

Mozilla Reps
reps.mozilla.org
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: tasos, Assigned: tasos)

Tracking

Details

(Whiteboard: [kb=1089065] )

Comment hidden (empty)
(Assignee)

Updated

4 years ago
Whiteboard: [kb=1089065]

Comment 1

4 years ago
Commits pushed to master at https://github.com/mozilla/remo

https://github.com/mozilla/remo/commit/d51f804a6d5057618d1a5c40349792b57b65fa26
[fix bug 908693] Show an error message if a user's email already exists.

https://github.com/mozilla/remo/commit/d0600c4f8861aa096913935a69360d714779ccbc
Merge pull request #470 from akatsoulas/908693

[fix bug 908693] Show an error message if a user's email already exists.

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 908219
Verified on stage.
Status: RESOLVED → VERIFIED
Version: 410 → 412

Comment 4

4 years ago
Is this the fix?

---
Email already exists. You probably used this email to sign in as a 'mozillian' into the portal. Please send an email to https://lists.mozilla.org/listinfo/reps-webdev to get help.
---
(Assignee)

Comment 5

4 years ago
Hi Brian,

Yes it is :). This fix just informs the user that the email is already in use. I believe that in your case, nemo should have your mozillian email removed by now from the db. Please have a look and if not ping me here or at #remo-dev on irc to remove it.

Comment 6

4 years ago
Resolved over IRC. Thanks.
You need to log in before you can comment on or make changes to this bug.