Closed Bug 908822 Opened 7 years ago Closed 7 years ago

Rendering glitch of tab progress icon and contents area if HWA is off

Categories

(Core :: Graphics, defect)

26 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26

People

(Reporter: alice0775, Assigned: mattwoodrow)

References

Details

Attachments

(3 files)

Attached image screenshot
After landing Bug 907926

I notice rendering glitch of tab progress icon if HWA is off.
This problem seems to happen in Aero / Windows7 Classic.

Steps To Reproduce:
1. Turn off HWA from Option and Restart browser
2. Open any page
    --- observe tab progress icon

Actual Results:
Icon background is black

Expected Results:
Render properly

Regression window(m-i):
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3ab03b70a92c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130822221923
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ed0b6a11532d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130822233723
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=3ab03b70a92c&tochange=ed0b6a11532d
Contents area is also affected.
Steps To Reproduce:
1. Open http://www.mozilla.org/en-US/firefox/customize/
2. Mouse over menu at top of the contents
3. Mouse over video playback button
Summary: Rendering glitch of tab progress icon if HWA is off → Rendering glitch of tab progress icon and contents area if HWA is off
This is really bad in Thunderbird.  The rendering is really screwed up.
This happens with HWA on as well.
(In reply to Alice0775 White from comment #1)
> Created attachment 794841 [details]
> screenshot affected contens area

My screen look similar with Win 8. Since nightly 23.8.13

Adapter Description	ATI MOBILITY RADEON X1600
Adapter Drivers	atiumdag atiumdva atitmmxx
Adapter RAM	Unknown
Device ID	0x71c5
Direct2D Enabled	Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
DirectWrite Enabled	false (6.2.9200.16581)
Driver Date	2-10-2010
Driver Version	8.593.100.0
GPU #2 Active	false
GPU Accelerated Windows	0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version 9.6 or newer.
Vendor ID	0x1002
WebGL Renderer	Blocked for your graphics driver version. Try updating your graphics driver to version 9.6 or newer.
windowLayerManagerRemote	false
AzureCanvasBackend	skia
AzureContentBackend	none
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
(In reply to TheRave from comment #5)
> (In reply to Alice0775 White from comment #1)
> > Created attachment 794841 [details]
> > screenshot affected contens area
> 
> My screen look similar with Win 8. Since nightly 23.8.13
> 
> Adapter Description	ATI MOBILITY RADEON X1600
> Adapter Drivers	atiumdag atiumdva atitmmxx
> Adapter RAM	Unknown
> Device ID	0x71c5
> Direct2D Enabled	Blocked for your graphics driver version. Try updating your
> graphics driver to version 10.6 or newer.
> DirectWrite Enabled	false (6.2.9200.16581)
> Driver Date	2-10-2010
> Driver Version	8.593.100.0
> GPU #2 Active	false
> GPU Accelerated Windows	0/1 Basic Blocked for your graphics driver version.
> Try updating your graphics driver to version 9.6 or newer.
> Vendor ID	0x1002
> WebGL Renderer	Blocked for your graphics driver version. Try updating your
> graphics driver to version 9.6 or newer.
> windowLayerManagerRemote	false
> AzureCanvasBackend	skia
> AzureContentBackend	none
> AzureFallbackCanvasBackend	cairo
> AzureSkiaAccelerated	0

Your GPU Driver is blocked. It means HWA = off.
Too many regressions :(

I'll keep working on them locally.
Attachment #795308 - Flags: review?(ncameron)
Comment on attachment 795308 [details] [diff] [review]
Disable Azure content

Review of attachment 795308 [details] [diff] [review]:
-----------------------------------------------------------------

:-(

Also, it would be nice to be able to flick this on and off with a pref in the short term.
Attachment #795308 - Flags: review?(ncameron) → review+
https://hg.mozilla.org/mozilla-central/rev/46406fd1787f
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Duplicate of this bug: 909033
Duplicate of this bug: 909165
I'm confused by this patch of turning azure.content

Is that just azure.content for basiclayers or gfx.content.azure.enabled in general ?

Not a coder and was not able to guess by reading the 'diff' of what was disbled.

The pref gfx.content.azure.enabled is still 'true' (default)
Confirming the 26.0a1 (2013-08-27) build no longer has any of the artifacts described here, in bug 909033, bug 909165 and bug 908811 on XP Classic without HWA.
Assignee: nobody → matt.woodrow
You need to log in before you can comment on or make changes to this bug.