Closed Bug 908844 Opened 9 years ago Closed 9 years ago

Add UTM parameters to Mozilla logo on about:home

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 27
Tracking Status
firefox26 --- fixed

People

(Reporter: cmore, Assigned: Gavin)

Details

Attachments

(1 file)

Within about:home in Firefox desktop on the top right is the Mozilla logo. That logo is linked to www.mozilla.org/about/. We would like to understand how much traffic is coming from the browser to www.mozilla.org. The reason that we cannot do it now is that since about:home is not a webpage the referring headers are blank and thus it looks like "direct" traffic. Since direct traffic can be any number of things, we cannot effectively segment the traffic to only traffic from the browser.

What we could do to solve this is to add UTM parameters to the URL so that we can say when a value of a query parameters equals a specific value, we know that it is from the browser. 

The code is here:

http://dxr.mozilla.org/mozilla-central/source/browser/base/content/abouthome/aboutHome.xhtml on line 70.

70 <a id="aboutMozilla" href="http://www.mozilla.org/about/"/>

Would just need to include UTM parameters after the /about/. Gareth Cull can advise on what the URL should be.
Gavin: Also, can you help get this one in front of the right eyes?

The new value should be:

70 <a id="aboutMozilla" href="http://www.mozilla.org/about/?utm_source=about-home&utm_medium=Referral"/>
While we're at it, let's also switch to https. Any objections?
Attached patch patchSplinter Review
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #812334 - Flags: review?(mak77)
https works for me!
Attachment #812334 - Flags: review?(mak77) → review+
OS: Mac OS X → All
Hardware: x86 → All
no objections from me, thanks for bringing this on.
Failed to properly escape the ampersand, how embarrassing:

https://hg.mozilla.org/integration/fx-team/rev/e373ba1b3ce7
When will this land in any of the Firefox release channels?
This landed in Firefox 27, so January 21st: https://wiki.mozilla.org/RapidRelease/Calendar

Seems safe to uplift to Aurora/Beta if there's a need for it, though.
(In reply to Justin Dolske [:Dolske] from comment #11)
> This landed in Firefox 27, so January 21st:
> https://wiki.mozilla.org/RapidRelease/Calendar
> 
> Seems safe to uplift to Aurora/Beta if there's a need for it, though.

I wouldn't mind an uplift to gauge the traffic levels sooner than later. Thanks
Comment on attachment 812334 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: N/A
Testing completed (on m-c, etc.): N/A
Risk to taking this patch (and alternatives if risky): no risk
String or IDL/UUID changes made by this patch: none

(see comment 12 for rationale)
Attachment #812334 - Flags: approval-mozilla-beta?
Attachment #812334 - Flags: approval-mozilla-aurora?
Comment on attachment 812334 [details] [diff] [review]
patch

Too late in the cycle for Beta (even though we're 99.9% sure this wouldn't cause a regression). It's jut not critical enough to take any risk.
Attachment #812334 - Flags: approval-mozilla-beta?
Attachment #812334 - Flags: approval-mozilla-beta-
Attachment #812334 - Flags: approval-mozilla-aurora?
Attachment #812334 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.