B2G Emulator: b2g-ps fails with the shell inside the emulator

RESOLVED DUPLICATE of bug 828869

Status

RESOLVED DUPLICATE of bug 828869
5 years ago
5 years ago

People

(Reporter: julienw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR:
* run the emulator
* run the command: "adb shell b2g-ps"

Expected:
* we have the list of the processes running in the emulator

Actual: 
* we get an error:

  /system/bin/b2g-ps: 29: Syntax error: Bad substitution

We probably have a different shell in the emulator, but we also could make b2g-ps work with a minimal shell (like dash).

This makes working with Gaia in the emulator more difficult, because the automatic killing when pushing does not work because of that.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 828869
You need to log in before you can comment on or make changes to this bug.