json dump of todays builds busted

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: nthomas, Unassigned)

Tracking

({buildapi})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
via cron:

From: Cron <buildapi@buildapi01> /home/buildapi/bin/report-today.sh
Subject: Cron <buildapi@buildapi01> /home/buildapi/bin/report-today.sh

Traceback (most recent call last):
  File "/home/buildapi/src/buildapi/scripts/reporter.py", line 356, in <module>
    report = build_report(R, session, scheduler_db_engine, starttime, endtime)
  File "/home/buildapi/src/buildapi/scripts/reporter.py", line 163, in build_report
    slaves[slave_id] = get_slave_name(cache, session, slave_id)
  File "/home/buildapi/src/buildapi/scripts/reporter.py", line 85, in get_slave_name
    slave_name = s.name
AttributeError: 'NoneType' object has no attribute 'name'

With a little logging 
trying to get slave name for slave id 1893, in builders {'category': 'fx-team', 'master_id': 40, 'name': 'fx-team_tegra_android_test-jsreftest-3', 'slaves': [1893, 1667, 1661, 1838, 1659, 1837, 1657, 1836, 1655, 1835, 1654, 1653, 1834, 1833, 1832, 1831, 1177, 1198, 1175, 1830, 1829, 1828, 1171, 1891, 1826, 1825, 1824, 1823, 1851, 1196, 1820, 1169, 1656, 1648, 1647, 1646, 1645, 1644, 1651, 1642, 1641, 1154, 1153, 1125, 1151, 1179, 1178, 1863, 1665, 1819, 1818, 1817, 1816, 1815, 1814, 1813, 1812, 1811, 1810, 1809, 1808, 1167, 1152, 1128, 1869, 1174, 1176, 1170, 1166, 1195, 1194, 1375, 1353, 1352, 1350, 1372, 1371, 1356, 1354, 1360, 1361, 1807, 1850, 1806, 1805, 1804, 1803, 1802, 1801, 1663, 1668, 1800, 1868, 1857, 1859, 1860, 1870, 1163, 1193, 1160, 1159, 1158, 1157, 1156, 1155, 1172, 1149, 1168, 1359, 1368, 1370, 1369, 1357, 1366, 1363, 1367, 1355, 1364, 1799, 1798, 1797, 1796, 1795, 1794, 1793, 1792, 1677, 1676, 1675, 1866, 1865, 1864, 1791, 1862, 1827, 1203, 1202, 1201, 1200, 1199, 1789, 1197, 1892, 1365, 1362, 1788, 1192, 1191, 1787, 1786, 1165, 1691, 1854, 1853, 1852, 1664, 1666, 1785, 1784, 1660, 1164, 1561, 1549, 1543, 1542, 1541, 1540, 1538, 1821, 1536, 1535, 1146, 1145, 1144, 1142, 1141, 1140, 1139, 1783, 1782, 1137, 1136, 1679, 1781, 1780, 1779, 1678, 1358, 1126, 1351, 1662, 1559, 1558, 1124, 1556, 1555, 1554, 1552, 1551, 1550, 1856, 1777, 1855, 1775, 1774, 1773, 1772, 1771, 1759, 1770, 1182, 1127, 1135, 1546, 1545, 1544, 1548, 1652, 1643, 1650, 1649, 1640, 1639, 1769, 1173, 1861, 1867, 1138, 1134, 1133, 1132, 1131, 1130, 1348, 1129, 1347, 1349, 1768, 1767, 1766, 1765, 1764, 1763, 1762, 1761, 1858]}
(Reporter)

Comment 1

5 years ago
There's no slave with id 1893 in the slaves table, but there were 1575 records in the builder_slaves table with that slave_id. So then reporter.py does this:
https://hg.mozilla.org/build/buildapi/file/default/buildapi/scripts/reporter.py#l131
and has a problem.

In the end catlee deleted 31066 rows from builder_slaves where the slave didn't exist, but we also had to remove all the builders:* keys from redis. We don't understand the cause of the problem because catlee's db cleanup scripts didn't touch the slaves or builder_slaves tables.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.