[Helix][Usage] The usage app cannot display the chart.

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: whsu, Assigned: salva)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 795177 [details]
Chart of data usage

* Description:
  This case happened on Helix build. The previous build didn't have the problem.
  If you open the usage app, you cannot see the chart of data usage.
  Attaching the screenshot.

* Reproduction steps:
  1. Launch the usage app

* Expected result:
  The main page displays the chart of data usage.

* Actual result:
  The chart disappeared.

* Reproduction build:(Mozilla-b2g18_v1_1_0_hd-helix/2013-08-24-04-22-02)
  + Mercurial-Information
    - Gecko revision="f392714dea0b"
  + Git-information
    - Gecko revision="a87463bf8387cc5001824a6411f7cd0497bb8649"
    - Gaia revision="7b61b7dc3400d5bea23d2b52948f4fded8259dfc"


Thanks!
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?

Comment 1

5 years ago
Sometimes this issue will be reproduced with the following STR:

1.Flash the device and set the system date to 1980 in FTU
2.Configure the Usage app
3.Check the Usage app,only check-boxes and settings will be visible,but not the Usage Chart.

I think Cost control application is requesting the Data samples from 1980 to present day.
That is the reason the chart is not shown,wait for 10 to mins,can see the chart.

Comment 2

5 years ago
Created attachment 796512 [details]
Bug_909132.txt

Logs are attached.

Comment 3

5 years ago
(In reply to Leo from comment #1)
> Sometimes this issue will be reproduced with the following STR:
> 
> 1.Flash the device and set the system date to 1980 in FTU
> 2.Configure the Usage app and check the chart.It will be shown.
> 3.Now change the system date to today date(Aug 28 2013)
> 3.Check the Usage app,only check-boxes and settings will be visible,but not
> the Usage Chart.
> 
> I think Cost control application is requesting the Data samples from 1980 to
> present day.
> That is the reason the chart is not shown,wait for 10 to mins,can see the
> chart.
Assignee: nobody → salva
Created attachment 796580 [details]
Adding a minimum date in order to limit the time window to query for.
Attachment #796580 - Flags: review?(francisco.jordano)
Attachment #796580 - Flags: feedback?(leo.bugzilla.gaia)
Attachment #796580 - Flags: feedback?(acperez)
blocking-b2g: hd? → leo?

Comment 5

5 years ago
Comment on attachment 796580 [details]
Adding a minimum date in order to limit the time window to query for.

Looks fine
Attachment #796580 - Flags: feedback?(acperez) → feedback+

Comment 6

5 years ago
Comment on attachment 796580 [details]
Adding a minimum date in order to limit the time window to query for.

Patch is working fine in Leo.(For Leo only costcontrol.js changes are required)

Once again Thank You Salva.
Attachment #796580 - Flags: feedback?(leo.bugzilla.gaia) → feedback+
Comment on attachment 796580 [details]
Adding a minimum date in order to limit the time window to query for.

Looking good to me.

Thanks Salva!
Attachment #796580 - Flags: review?(francisco.jordano) → review+
Master: 3900b53a815eb60605aa52107736c2ba391110e3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Leo, if you want this in v1-train, please flag it as leo+ for uplifting.
Flags: needinfo?(leo.bugzilla.gaia)

Updated

5 years ago
blocking-b2g: leo? → leo+
Flags: needinfo?(leo.bugzilla.gaia)
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 3900b53a815eb60605aa52107736c2ba391110e3
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(salva)
v1-train: a03cd222f244ef8cbc6a7a2647de324fdfc40215
Flags: needinfo?(salva)
v1.1.0hd: a03cd222f244ef8cbc6a7a2647de324fdfc40215
status-b2g-v1.1hd: --- → fixed
status-b2g18: --- → fixed

Comment 13

5 years ago
Verified fixed on

Leo moz ril Build ID: 20130906041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/85cb54136ddb
Gaia: a7b8037f1f1bcafcfd5fbad7cd74f7e22bb80166
Platform Version: 18.1

The main page displays the chart of data usage.  Also tried by changing date to 1980 and chart is displayed correctly.
status-b2g18: fixed → verified
(Reporter)

Comment 14

5 years ago
Verified on V1.1.0 hd

* Test build:(Mozilla-b2g18_v1_1_0_hd-helix/2013-09-09-04-22-04)
  + Mercurial-Information
    - Gecko revision="4b09975b2d7c"
  + Git-information
    - Gaia revision="75228cd1223c22642623e99c37f7bc8b2a355d86"
  + Gecko version: 18.0
Attaching the screenshot.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 15

5 years ago
Created attachment 802230 [details]
UsageApp - Chart
You need to log in before you can comment on or make changes to this bug.