Aurora considers addons installed while using the nightly build to be from a third party program, prompts to block installation

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
5 years ago
a year ago

People

(Reporter: Robbie Ward, Unassigned)

Tracking

26 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130825030201

Steps to reproduce:

Using a nightly profile, install an addon.
Close nightly, and open Aurora using the same profile 


Actual results:

Aurora opens the 'third party addon installation' prompt page where it asks if you want to block the installation.


Expected results:

Aurora should not open the prompt page
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20131020004007

Works fine for me when using the latest Aurora and installing add-ons from addons.mozilla.org (the only dialog I get is the Checking Compatibility of the Add-ons one).

Robert, could you please be more specific regarding the add-on you installed?
Component: Untriaged → Add-ons Manager
Flags: needinfo?(rjward0)
Product: Firefox → Toolkit
(Reporter)

Comment 2

5 years ago
Using nightly, install any addon

After installing the addon, restart nightly.

Close nightly, and using the same profile, open Firefox (I did this with release, likely the same behavior on any other build though) 

You'll be presented with the third party installation screen

http://imgur.com/a/pnAdm
Flags: needinfo?(rjward0)
(Reporter)

Comment 3

5 years ago
I've observed this behavior for any given addon installation, and it has persisted through a profile reset.
I was able to reproduce this issue on Firefox 26.0a1 and Firefox 25.0a2 under Windows 10 64-bit excepting the first time when the following “Select Your Add-ons” window was prompted: http://screencast.com/t/vRhrBnnRur0s

But, I did not managed to reproduce it on Firefox 53.0a1 (2017-01-09), Firefox 52.0a2 (2017-01-09), Firefox 51.0b12 (20170105155013) and Firefox 50.1.0 (20161208153507) under Windows 10 64-bit.
It seems to be fixed across the way.


Is this issue still reproducible on your end?  If yes, can you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ?
Flags: needinfo?(rjward0)
(Reporter)

Comment 5

a year ago
seems to be fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(rjward0)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.