[modern] The background of navigation toolbar wrongly displayed.

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
17 years ago
4 years ago

People

(Reporter: swhui, Assigned: pavlov)

Tracking

({modern})

Trunk
Future
x86
All
modern
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.2) Gecko/20010713
BuildID:    2001071322

Reproducible: Always
Steps to Reproduce:
1.Install Linux-Mandrake 8.0 (without Mozilla)
2.Install Mozilla 0.9.2 using Redhat RPM or RPM from Linux Mandrake Cooker
3.Change to Modern Theme

Actual Results:  The Classic Theme is working fine but not Modern Theme's
navigation toolbar's background.  It doesn't have problem in Win32 build on
Windows 98.

Can provide screenshot (how? I'm new)
(Reporter)

Comment 1

17 years ago
Created attachment 42360 [details]
This is the screen capture of the problem.
(Reporter)

Comment 2

17 years ago
Created attachment 42361 [details]
So as mail and news.
(Reporter)

Comment 3

17 years ago
Similar to bug #88576
Keywords: modern

Comment 4

17 years ago
smells like libpr0n. ewww.
Assignee: hewitt → pavlov
Component: Themes → ImageLib
(Reporter)

Comment 5

17 years ago
Actually the Personal Toolbar has the same trouble, but I didn't notice as I 
turned the Personal Toolbar off.  All other things looks fine.

Let me know any further information for reproductible results. My hardware:
K6-II+ 400MHz on Asus T2P4(rev2.3), 96MB Ram, 10GB IDE Harddisk on Promise 
Fasttrak66 controller, WinFast S280 (S3 Trio64V+ Chipset, 2MB), SB16, PCI 
10/100Mb NIC, 28.8 ISA Modem.

Comment 6

17 years ago
Taylor, try a recent nightly build. This appears to be fixed in the nighthlies.
(Reporter)

Comment 7

17 years ago
Created attachment 42468 [details]
Diego, I've tried, and it still doesn't work.  Maybe it's just me?
(Reporter)

Comment 8

17 years ago
Created attachment 42671 [details]
Got this trouble on Hotmail's page. Looks like libpr0n problem.
(Reporter)

Comment 9

17 years ago
I was using XF86_S3 (Linux-Mandrake 8.0 comes with ver3.3.6) at 800x600 24bit
depth. Tried change color depth, the problem still exists. Then switched to
1024x768 16bit depth. Problem had gone. Switched back to 800x600, problem came
back. Then switched to 640x480, problem had gone again.

Then switched back to 800x600x16. Problem did not come back as expected. Mozilla
was started at 640x480 size, but maximized it didn't reproduce the problem, nor
restarting it.  Now everything is fine. Even the Hotmail page render properly.

This glitch is related to mozilla, as I haven't seen any display glitch
elsewhere so far.

Don't know whether we should be happy about it.

Comment 10

17 years ago
I am seeing display problems with the navigation toolbar background too. I am
using Mozilla 0.9.2 (Build ID 2001062815) on Windows NT. My Video Adapter is an
ATI Technologies Inc. 3D RAGE PRO.

Comment 11

17 years ago
Created attachment 42841 [details]
Screen capture of incorrect Toolbar background on Win NT

Comment 12

17 years ago
Colin, Taylor, I am sbsolutely convinced this is a problem only in milestone
0.9.2, I saw it, too, intermittently. Please download a nightly build and verify
the problem with that nightly (and please do not forget to post the build
number). Thanks.

Changing OS to All.
OS: Linux → All

Comment 13

17 years ago
I downloaded Nightly build 2001071803 - the problem appears to be fixed.
(Reporter)

Comment 14

17 years ago
Created attachment 42930 [details]
This is 2001071804, still problematic
(Reporter)

Comment 15

17 years ago
This bug comes back today on my 2001071322

So, tried some builds, here are the summaries

No problem builds
2001032614 (0.8.1)
2001050521 (0.9)

builds with problem
2001061713 (0.9.1)
2001071322 (0.9.2)
2001071608 (from trunk)
2001071721 (trunk)
2001071804 (0.9.2)
2001071821 (trunk)
2001071913 (trunk)

Should I post the screen captures?  All are under 800x600x16, the same XF86_S3 
Each one tried with clean install and clean profile (use the .tar.gz packages)

I think the bug was in 0.9.2 and it was not completely cleaned.

Comment 16

17 years ago
This bug is quite familiar. I orginally found this problem. Here it is:
http://bugzilla.mozilla.org/show_bug.cgi?id=80967
Recently, I thought this bug is fixed, I could not reproduce it any more.

Comment 17

17 years ago
Taylor, you convinced me, this problem must be for real.

--> NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 18

17 years ago
I just checked in a large change to backgruond images.  please see if this is 
still happening.
Keywords: qawanted
(Reporter)

Comment 19

17 years ago
Created attachment 45873 [details]
Both 2001080915 (the one with imagelib landed) and the trunk 2001081008 still have the same problem.  S3 XFree86 Server problem?
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future

Comment 20

17 years ago
Taylor Hui: Are you still seeing this paint problem with recent builds?

Comment 21

17 years ago
No reaction for almost two months.  Marking WORKSFORME.  Taylor, reopen the bug
if you still have problems with a current build.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 22

17 years ago
My Mandrake Linux 8.1 was down.  Now using Mandrake 8.2 (and xfree86 4.2), the 
packaged mozilla 0.9.8 is working fine for me now.  Even Hotmail's page is 
working.

Comment 23

17 years ago
Taylor, the next time please mark the bug VERIFIED if you cannot reproduce
anymore as reporter.  Thanks.

Marking VERIFIED.
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.