[MP] Defect - Pressing the "Previous" or "Back" buttons doesn't dismiss the App Bar if its currently visible

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Samvedana, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [preview] feature=defect c=tbd u=tbd p=0)

Reporter

Description

6 years ago
Steps to reproduce the issue:

1) Open Firefox Metro
2) Go to any website (doesn't matter which one)
3) Open the App Bar using Windows + Z
4) Select the "Pin" icon and accept the "Pin to Start" window
5) Select the "Back" or "Forward" button and you will notice that the App Bar isn't dismissed and the "Pin" icon is still enabled

Actual Results:

- Pressing the "Previous" or "Back" buttons doesn't dismiss the App Bar and makes it look like the current website is also pinned

Expected Results:

- Pressing the "Previous" or "Back" buttons should dismiss the App Bar if its currently visible.

Updated

6 years ago
Depends on: 903740
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0
Summary: Defect - Defect - Pressing the "Previous" or "Back" buttons doesn't dismiss the App Bar if its currently visible → [MP] Defect - Pressing the "Previous" or "Back" buttons doesn't dismiss the App Bar if its currently visible
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0 → [preview] feature=defect c=tbd u=tbd p=0
QA Contact: jbecerra
I think showing the appbar is the correct behavior. And for me the appbar icon state adjusts correctly to the new page that is loaded (whether it is pinned or not).

Resolved / WFM?
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Showing the appbar is how it should work.  The buttons not updating worked for me. If anyone else can reproduce this, please re-open.
No longer blocks: metrov1backlog
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.