If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RFE] Turbo mode should be ON by default (here's why...)

VERIFIED WONTFIX

Status

SeaMonkey
Installer
--
enhancement
VERIFIED WONTFIX
16 years ago
13 years ago

People

(Reporter: Peter Lairo, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2+) Gecko/20010714

Turbo mode should be ON by dafault (here's why):

- Most "regular" users just breeze through the install process, clicking on next
without really looking at the options. These are the ones that use the "standard
installs" (and often don't know an OS from an app). They are often fearful of
changing any setting from its default. These are also the users who say: "IE
loads so much faster". These are the ones we need to have the turbo switch on for.

- Having the turbo option clearly selectable during installation gives the more
thoughtful and discerning user an easy oportunity to turn off turbo and never
bother with it again.

In summary:
- The ones that need the turbo switch the most are the ones who don't know to
turn it on.
- The ones who might not want it are the ones who know how to easily turn it off.

THEREFORE, the default should be ON.
(Reporter)

Updated

16 years ago
Keywords: mozilla0.9.3
Whiteboard: VERY easy to fix.

Comment 1

16 years ago
This is an [RFE] and the summary and severity should be changed to reflect that.
(Reporter)

Comment 2

16 years ago
OK, done.
Severity: minor → enhancement
Summary: Turbo mode should be ON by dafault (here's why) → [RFE] Turbo mode should be ON by dafault (here's why...)
I'd personally say no to this one, until we have a serious reduction in memory
footprint...
(Reporter)

Comment 4

16 years ago
Even if our footprint is (slightly?) elevated, the *perception* of most users is
what is more important, especially with most PC's now having 128-256 MB RAM.
Experienced users (who even know what a footprint is) can *easily* turn it off.

BTW. What is our current footprint vs. IE5.5?

Comment 5

16 years ago
and here's the reason why *not* to have it on as default:
1) IE is already in memory and the user may not want to waste all their memory
on keeping web browsers resident in particular if they never browse the web.
2) I know a lot of people who hate apps that install themselves on startup and
then they have to manually remove it. Too many apps do this already without
asking and the system tray is cluttered.
3) Many machines do not have enough memory to comfortably run moz and a few
other applications. Remember, many people are still running machines with 32MB
memory and 64MB is very common still. Running moz in -turbo mode will cause a
noticable slowdown on these machines and a user may not know why.

You're saying that the people who don't want preloading know how to disable it.
This is just not true, there may be loads of people who just install mozilla on
a low spec machine, their system grinds to a halt but they don't know why
because Mozilla hasn't been launched they don't expect that.

I know people who don't use realplayer on principle just because it launches by
default on startup, they know how to disable it but they don't believe an app
should start up like this, how do you think they're gonna react to Mozilla which
uses more memory than most other apps that do this.

This has to be a wontfix, and must not seriously be considered until memory
footprint goes down and machine specs go up. But then I'd still argue it should
be off by default, it's a bad practice that many apps are starting to do this,
and things will get worse if more apps default to this state, memory is not
infinite so we shouldn't waste it by default. Remember some people may install
mozilla and use it at most monthly. On these super fast high memory machines
where people won't notice the memory used up by turbo mode, moz is pretty fast
anyway, doesn't start up as quick as IE but fast enough not to cause complaints,
but people on the slow machines will just notice a general system slowdown when
mozilla isn't even running, and additional wear on their hard drive as the
swapfile keeps being accessed.

The point is you don't have to be an experienced user to have a slow machine and
hopefully in the future ISPs will distribute mozilla in some form on a CD, if
one of these newbie users installs mozilla and their system slows down without
them even launching moz then they're not gonna know how to fix it.

What might be good is a mozilla distribution bundled with 98lite
http://98lite.net/ this could uninstall all the IE components and then replace
with mozilla -turbo therefore only having one browser in memory. If you think
that's a good idea contact the authors of 98lite and suggest that they should
package their product with mozilla.

Updated

16 years ago
Assignee: asa → ssu
Component: Browser-General → Installer
QA Contact: doronr → gemal

Comment 6

16 years ago
-> Installer

Comment 7

16 years ago
>I know a lot of people who hate apps that install themselves on startup and
>then they have to manually remove it.

Its me, I dont think that the bug request is a good idea( hey wasn't that polite?)

Comment 8

16 years ago
I also usually hate apps that have this behaviour, but Peter Lairo has some good
points. There is a danger that this feature will go unnoticed by many people. 

I suggest it is kept off by default, but the option is made more visible in the
installer. It should have a text saying something like:

"Quick launch will make Mozilla start much faster, but may affect performance on
slow machines. You can enable/disable this feature at any time in the
preferences menu"

Comment 9

16 years ago
Yeah better wording in the installer (but defaulting off) is the way to go, but
I wasn't gonna comment on the installer as I've not seen the installer since the
addition of -turbo as when using win32 I use zipped builds

Comment 10

16 years ago
reporter: if it's very easy to fix then attach a patch.

I have a better idea, proposals to change behaviors should be expressed in a 
newsgroup. if no one complains w/in 4 weeks then someone should file a bug.  
Don't worry the odds of me getting to your proposal in a newsgroup are low 
because I'm about 2 years behind in ~20 mozilla groups (that's ~120k messages). 
however given that the people who have expressed concern here _do_ read 
and post to newsgroups I think it's a good idea.
OS: All → Windows 95
Whiteboard: VERY easy to fix.
WONTFIX, This is already an option, marking it on by default would be more
severe.. I agree that the option should be made more visible, maybe a bug should
be filed on that instead. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 12

16 years ago
verified
Status: RESOLVED → VERIFIED

Comment 13

16 years ago
This bug probably shouldn't keep its WONTFIX resolution now that it is actually
"fixed". 
(Reporter)

Updated

16 years ago
Summary: [RFE] Turbo mode should be ON by dafault (here's why...) → [RFE] Turbo mode should be ON by default (here's why...)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.