[Downloads.jsm] Add-ons:Download Manager Tweak 0.9.8 doesn't work

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
RESOLVED WORKSFORME
4 years ago
2 months ago

People

(Reporter: Wilhelm, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130826030203

Steps to reproduce:

Doewnload


Actual results:

Only popup but no content and further actions 


Expected results:

Worked in 26.0a1 some days ago, woks too in 24.0 beta.
(Reporter)

Updated

4 years ago
Priority: -- → P1
Version: 26 Branch → Trunk
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0
This issue regressed when Downloads.jsm was introduced instead of the old nsIDownloadManager API.

Steps to reproduce:
1. Install the Download Manager Tweak add-on from https://addons.mozilla.org/en-US/firefox/addon/download-manager-tweak/?src=search
2. Restart the browser
3. Perform a download

Expected result: the add-on's downloads panel opens when the download starts and shows the download progress (and other downloads previously made, if available)

Actual result: the add-on's downloads panel doesn't open when the download starts. You can open it from the downloads indicator, but it doesn't show the downloads (it is empty)

Note: the issue is not reproducible with August 5 Nightly (which doesn't have the Downloads.jsm landed), nor by turning the browser.download.useJSTransfer preference to false.
Status: UNCONFIRMED → NEW
Component: Untriaged → Extension Compatibility
Ever confirmed: true
OS: Windows 8 → All
Priority: P1 → --
Hardware: x86_64 → All
Summary: Add-ons:Download Manager Tweak 0.9.8 → [Downloads.jsm] Add-ons:Download Manager Tweak 0.9.8
Summary: [Downloads.jsm] Add-ons:Download Manager Tweak 0.9.8 → [Downloads.jsm] Add-ons:Download Manager Tweak 0.9.8 doesn't work
The developers have been notified.

Updated

4 years ago
Blocks: 907764

Comment 3

2 months ago
Closing the old compatibility bug now that legacy extensions are not supported anymore.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.