Regression: URL mismatch from content; toolbar not properly animated

RESOLVED DUPLICATE of bug 906041

Status

()

RESOLVED DUPLICATE of bug 906041
6 years ago
5 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({regression, reproducible})

26 Branch
ARM
Android
regression, reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 795504 [details]
device-2013-08-26-130558.png

Occasionally I get into a situation where I see content mismatched between the present URL. 

When that happens, the toolbar also does not resize properly out from editing mode in the new about:home to expose the traditional tab button and menu for proper browser navigation. 

See screenshot.

I can reproduce this using 'non-traditional' based methods, but I have hit this a few times by accident as well - those steps I'm still investigating.

Steps to reproduce (non-traditional method)

1. Tap the URL bar to enter editing mode, visit any site (e.g, yahoo.com)
2. Tap the URL bar again to re-enter editing mode
3. Feed a new URL to fennec on command line, i.e, 

adb shell am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App http://mozilla.com

What you get is what you'll see in my attached screenshot.

--
Nightly (08/26) | LG Nexus 4 (Android 4.3)
(Reporter)

Updated

6 years ago
Component: General → Awesomescreen
Dupe of bug 907192?
To make the attached screenshot, I assume you loaded http://google.com from the command line.

This sounds more like a dupe of bug 906041.
(Reporter)

Comment 3

6 years ago
(In reply to :Margaret Leibovic from comment #2)
> To make the attached screenshot, I assume you loaded http://google.com from
> the command line.

No; visited the site first as the norm. After loading Google, I tapped the address-bar to enter editing mode, and then I fed in a URL on command line.

I'm not sure how I wound up on this state in other occasions but I stumbled upon the non-traditonal steps above which wound up in the same state.

> This sounds more like a dupe of bug 906041.
Here is another possible example.

Tap on a link in the page. While it loads, tap on the url bar (with the old url). Hit back from the editing mode to dismiss keyboard. The url bar will still hold the old url as it was editing it. But the page will show new content -- totally mismatched.

I guess we should resort to "hitting back while editing should close editing mode"
Marking as dup. Seems like one more case of broken state when URL changes while in editing mode.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906041
tracking-firefox26: ? → ---
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.