Add info about what characters are supported in the collection slug

RESOLVED FIXED

Status

Marketplace
Admin Tools
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: basta)

Tracking

Points:
---

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 795540 [details]
slug.png

steps to reproduce:
1. Load https://marketplace-dev.allizom.org/curation/new_collection?type=basic
2. Enter collection name "0 0 0 0"
3. Notice that the slug gets auto generated
4. Notice that the 'Create' button remains disabled.

expected behavior:
We inform users about what characters are allowed in the slug.

observed behavior:
Slug gets auto generated with unallowed characters and collection creation is blocked. The error message 'This field is required' is inaccurate in this scenario.
(Assignee)

Comment 2

5 years ago
Interesting. I'll have a look.
Assignee: nobody → mattbasta
Status: NEW → ASSIGNED
(Assignee)

Comment 3

5 years ago
https://github.com/mozilla/rocketfuel/commit/40c580b6e65d59a444b979a8b55b6b7fa48c746b

Fixed. Since we weren't updating the `value` attribute on the element, the CSS knew it was invalid but didn't know it had a value.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.