Closed Bug 909432 Opened 7 years ago Closed 7 years ago

Unify and rename RESFILES and RES_FILES

Categories

(Firefox Build System :: General, defect)

All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla27

People

(Reporter: nalexander, Assigned: nalexander)

Details

Attachments

(1 file)

We have an unfortunate typo where config/rules.mk expects RESFILES and everywhere else expects RES_FILES.  (This is all for Android resource files.)  We should fix this.  But both those names are also used for different things in the tree, so we should find a better name for this -- I propose ANDROID_RESFILES (to be consistent with JAVAFILES).
Comment on attachment 795552 [details] [diff] [review]
Unify RESFILES and RES_FILES, and rename both to ANDROID_RESFILES. r=gps

Review of attachment 795552 [details] [diff] [review]:
-----------------------------------------------------------------

http://picardfacepalm.com/

I verified that other occurrences of RES_FILES in the tree appear to be not part of our build.
Attachment #795552 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/b3260513f700
Assignee: nobody → nalexander
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.