Page action prompts a 'complete action via' dialog without the expected native application

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({reproducible})

26 Branch
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Prerequisite: Install Github Mobile
https://play.google.com/store/apps/details?id=com.github.mobile

Went to Github, tapped the page action icon expecting Github Mobile to open. Instead, I got the 'Complete Action Via' dialog. Tapping any browser just reloaded Github and did not open the native application.

--
Nightly (08/26) | LG Nexus 4 (Android 4.3)
(Reporter)

Comment 1

5 years ago
Created attachment 795565 [details]
Nightly (08/26) Screenshot
(Reporter)

Comment 2

5 years ago
Re-summarizing. We offer for multiple choices like VLC & Gallery to handle video, but in this case Github Mobile was missing from the dialog. Maybe some redirection issues here?
Summary: Page action prompts a 'complete action via' dialog → Page action prompts a 'complete action via' dialog without the expected native application
Strange. If I make this an implicit intent, Github shows up in the list.
Ahh. This is a github thing I think:

https://github.com/github/android/blob/master/app/src/main/java/com/github/mobile/ui/user/UriLauncherActivity.java?source=cc#L102

They register one activity for all github.com urls, and if the url doesn't point to a repository or a gist or something they have a specific UI for, they throw it back out to the browser. I'll file a bug for them.
(Reporter)

Comment 5

5 years ago
I/ActivityManager(  533): START u0 {act=android.intent.action.VIEW dat=https://github.com/ flg=0x4000000 cmp=com.github.mobile/.ui.user.UriLauncherActivity} from pid 6741

I/ActivityManager(  533): START u0 {act=android.intent.action.VIEW cat=[android.intent.category.BROWSABLE] dat=https://github.com/ cmp=android/com.android.internal.app.ResolverActivity} from pid 8160

It's using 'https://github.com', so the prompt shows back up to prompt to handle it.
Marking invalid since we're doing things correctly here. I filed an issue with the github app as well: https://github.com/github/android/issues/400
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
tracking-firefox26: ? → ---
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.