Closed Bug 909447 Opened 8 years ago Closed 8 years ago

Assertion failure: !JS_IsExceptionPending(cx), at shell/js.cpp

Categories

(Core :: JavaScript Engine, defect)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
mozilla26

People

(Reporter: gkw, Unassigned)

Details

(Keywords: assertion, testcase)

Attachments

(1 file)

Attached file stack
function f(code) {
    try {
        g = Function(code)
    } catch (e) {}
    g()
}
f("\
    Object.defineProperty(this,\"x\",{\
        get: function(){\
            evaluate(\"Array(x)\",{\
                newContext:true,\
                catchTermination:(function(){})\
            })\
        }\
    })\
");
f("x");
f(")");
f("x");

asserts js debug threadsafe shell on m-c changeset 69d61f4ce0a9 with --baseline-eager --ion-parallel-compile=on at Assertion failure: !JS_IsExceptionPending(cx), at shell/js.cpp

Tested on https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-macosx64-debug/1377436285/jsshell-mac64.zip

This seems no longer reproducible with http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-08-26-mozilla-central-debug/jsshell-mac64.zip

If this is somehow fixed, we should land this testcase.
Flags: in-testsuite?
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #2)
> Backed out.
> https://hg.mozilla.org/integration/mozilla-inbound/rev/b2e8b8887816


(Actually this test never landed, the testcase in bug 909441 got landed in place instead)
bug909441, where the test landed, has been RESOLVED FIXED.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Flags: in-testsuite? → in-testsuite+
Target Milestone: --- → mozilla26
Thanks! However, since the patch that supposedly fixes this is unknown, resolving WFM instead.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.