[PS] Unix Print: Add CUPS printing dialog

VERIFIED DUPLICATE of bug 135695

Status

()

Core
Printing: Output
--
enhancement
VERIFIED DUPLICATE of bug 135695
17 years ago
16 years ago

People

(Reporter: Tobias Burnus, Assigned: rods (gone))

Tracking

Trunk
Future
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
There are currently three (major) possibilities to print under Unix:
- LPD
- CUPS
- XPRINT
The first allows not a lot of options and the last is out of scope of this bug.

CUPS allows you to set the output tray, douplex, resulution etc.

This bug is about implementing a printing dialog which is used when CUPS is
installed on the system. (CUPS can also be used with "lpr -o number-up=2 ..." so
it is backward compatible.)

Many Linux dist. allow now to choose between CUPS and LPD so the number of UNICS
which use CUPS will rise.

Comment 1

17 years ago
Future
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → REMIND
Target Milestone: --- → Future
*** Bug 109816 has been marked as a duplicate of this bug. ***
REMIND is deprecated per bug 35839.
Status: RESOLVED → REOPENED
Resolution: REMIND → ---
->rods
Assignee: dcone → rods
Status: REOPENED → NEW

Comment 5

16 years ago
We already have Xprint which provides this API (but our current XUL-dialog on
Unix/Linux does not reflect this yet).
It may be a better idea to fix this in two steps:
- Add support for the missing properties to the print job options dialog (the
Xprint glue ("xprintutils", see gfx/src/xprint/) already supports this)
- Add CUPS-support to the Xprint server side (Xprt)

Comment 6

16 years ago
With the major Linux distributions installing CUPS by default, this item appears
to be critical now. SuSE 8.1 installs CUPS as default now, and I believe it has
been this way at least since SuSE 8.0. The only way to print right now is to
print into a file and print that, and that is really annoying.

Comment 7

16 years ago
You don't have to print to a file...  I print to my cups printer all the time. 
Cups supplies an "lpr" command.  Make your printer PostScript/default, and under
properties make your print command "lpr -P printername"

Comment 8

16 years ago
Nah, doesn't work for me. I fiddled around with this for some time now, and whatever I do, I get a whooole bunch of empty pages. Tried 'lpr', 'lp', 'kprinter' and whatever else I could find but it is always the same result: empty pages. I can print fine from other apps like Acrobat Reader, but Mozilla simply doesn't work, no matter what I do. 

Comment 9

16 years ago
This is a problem with your computer then...  Let's not spam the bug any more. 
I'd be happy to help you with your problem.  If you'd like, email me directly.

Comment 10

16 years ago
Stefan raspl wrote:
> With the major Linux distributions installing CUPS by default, this item 
> appears to be critical now.

We had this discussion multiple times before.
Relying on CUPS API will cause incompatilities (e.g. it's likely that we would
have to ship two kinds of binaries then - one for CUPS and one for the others)
with other printing systems - there is more than one print system on Linux (like
LPng etc. etc.), and the various Unix-versions have all their own print system
(API) variants, too.
And the benefit of using the CUPS API within Mozilla doesn't seem to be a great
benefit beyond getting the |MOZILLA_PRINTER_LIST|-env var populated
automagically.
Summary: Unix Print[PS]: Add CUPS printing dialog → [PS] Unix Print: Add CUPS printing dialog

Comment 11

16 years ago
Would it be possible to somehow create the generic framework to plugin to
various window manager's printer tools?  I know that KDE has a very nice
printing framework available (at least from the end user perspecive)...  Or
would that be unreasonable because there's no good standard way of doing it. 
Does anyone know if Gnome offers a similar framework that could be plugged into?
 Any work that the Mozilla people do would really be duplicating work that's
already been done.

Just a thought...

Comment 12

16 years ago
Nick Pietraniec wrote:
> Would it be possible to somehow create the generic framework to plugin to
> various window manager's printer tools?  I know that KDE has a very nice
> printing framework available (at least from the end user perspecive)... 
> Or  would that be unreasonable because there's no good standard way of
> doing it. 

On Unix the single desktop frameworks all implement their own print dialogs (for
example: CDE has it's own based on Xprint, KDE uses the Qt framework etc.).
Since there isn't solution which would make all people "happy" Mozilla
implements it's own print dialog on Unix based on it's own widget set ("XUL" :)
(BTW: IMHO we would have far less problems (not only with printing :) if Mozilla
would be based on the Qt toolkit instead of the GDK/GTK+ libs...).

> Does anyone know if Gnome offers a similar framework that could be plugged 
> into?

No, there isn't such a thing yet.

> Any work that the Mozilla people do would really be duplicating work that's
> already been done.

Well, the functionality of obtaining the list of installed printers
automagically, supporting multiple different types of printers, support for
non-ISO-8859-1 locales, downloading fonts, Truetype font support and lots of
other nice stuff is supported via the Xprint module (see
http://mozilla.org/releases/mozilla1.0/#printing for references).

Or short: The functionality you want is already there - you only have to
configure it.

Comment 13

16 years ago

*** This bug has been marked as a duplicate of 135695 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 14

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.