Closed Bug 909564 Opened 6 years ago Closed 6 years ago

[B2G] [Buri] [1.2] [YouTube] Videos stutter almost to the point of unplayability

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, firefox26 fixed)

RESOLVED FIXED
blocking-b2g koi+
Tracking Status
firefox26 --- fixed

People

(Reporter: ckreinbring, Assigned: sotaro)

References

Details

(Keywords: regression, smoketest, Whiteboard: burirun1)

Attachments

(1 file)

Description:
YouTube videos stutter and stop playing repeatedly as they are played.

Repro Steps:
1) Update Buri to Build ID: 20130826163255
2) Launch the browser and navigate to Youtube.com.
3) Select and play a video.
4) Observe the quality of the video as it plays.

Actual:
The video has a lot of pauses and stutters, with the audio doing the same.

Expected:
The video plays with no glitches or interruptions in both video and audio.

Environmental Variables
Build ID: 20130826163255
Gecko: http://hg.mozilla.org/mozilla-central/rev/14b1e8c2957e
Gaia: 23343e6ea3cc59c3ab0ac9188aaa657bd11da4fd
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
See attached logcat logs
Related or potential dupe of bug 901220.
Component: Gaia::Browser → General
Please give us examples of videos you are seeing this with. Thanks.
Component: General → Gaia::Browser
Component: Gaia::Browser → General
(In reply to Marcia Knous [:marcia] from comment #2)
> Please give us examples of videos you are seeing this with. Thanks.

http://t.co/ZqUDdiUfDr is one of mine -- search for The Killers, Mr. Brightside, on Youtube.com, and play the 1st HQ video.
Video playback have a huge problem until Bug 907745 is fixed.
(In reply to Sotaro Ikeda [:sotaro] from comment #4)
> Video playback have a huge problem until Bug 907745 is fixed.

Also Bug 908276 is necessary.
This issue also occurs on v1.2 Buri device. 
Playing the video from video app is not smooth.

Environmental Variables:
Build ID: 20130827040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/e42dce3209da
Gaia: 599214a0f41eece076dc83cd85f5b27f8cfe67f2
Platform Version: 26.0a1
RIL Version: 01.01.00.019.202
Depends on: 901224, 909851, 907745
blocking-b2g: --- → koi?
QA Contact: jcouassi
We have tried base builds 0823 and 0815 by themselves, without additional builds on them, they worked fine with youtube videos.  We don't have base build 20130808 to test, which we think is possibly the cause of the issue. Between using base build 20130808 and 20130815 with moz builds on top, we noticed the youtube issue. 

Tested these on both 0823 and 0815 base builds -


Build ID: 20130621031231
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ba8c86f1a56
Gaia: e2f19420fa6a26c4287588701efaec09a750dba1
Platform Version: 24.0a1

Build ID: 20130730030200
Gecko: http://hg.mozilla.org/mozilla-central/rev/3d40d270c031
Gaia: ba5ff211fbf6a930326cc6a0d4a1205a7528630b
Platform Version: 25.0a1
RIL Version: 01.01.00.019.172 

Build ID: 20130731030205
Gecko: http://hg.mozilla.org/mozilla-central/rev/c2b375f3a909
Gaia: 9bfceaa90e8b92a379432b67121afa3cd3f14c90
Platform Version: 25.0a1

Build ID: 20130802070203
Gecko: http://hg.mozilla.org/mozilla-central/rev/c489af94ada5
Gaia: 4b347e4e39b1716b68463dccc63c1b3eb49158b3
Platform Version: 25.0a1


Build ID: 20130805070203
Gecko: http://hg.mozilla.org/mozilla-central/rev/ad0ae007aa9e
Gaia: 0ca0dba246d1372eb815772c8108395ab0abd0a4
Platform Version: 25.0a1

Build ID: 20130809040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/e33c2011643e
Gaia: c354940fbe112bcf2d90e2a5654ad1824f3a2348
Platform Version: 26.0a1

Build ID: 20130811040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/3d20597e0a07
Gaia: 1b9019acdc1eea9cfe78edeb914eba6e8153fbbe
Platform Version: 26.0a1
Okay. Given Sotaro's comments, I think we know what we need to fix here to resolve this, so I'm pulling regression window wanted.
Sotaro, are you the right person to look into this?
Assignee: nobody → sotaro.ikeda.g
blocking-b2g: koi? → koi+
(In reply to Alex Keybl [:akeybl] from comment #9)
> Sotaro, are you the right person to look into this?

Yes, the problem could be fixed by Bug 907745 and Bug 901224.
Unable to repro on today's Buri 1.2 mozilla RIL.  YouTube videos play from beginning to end with no stuttering.  Resolving as Worksforme.

Build ID: 20130913040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/b9029b1de410
Gaia: 8ccb741b6adcfe9a78b842c17e5874242c0f8b86
Platform Version: 26.0a1
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Actually, let's say fixed here by bug 907745 and bug 901224.
Resolution: WORKSFORME → FIXED
Whiteboard: burirun1
You need to log in before you can comment on or make changes to this bug.