All users were logged out of Bugzilla on October 13th, 2018

js can't change table border color if border-width specified in pt or px ...but ex, em work

VERIFIED WORKSFORME

Status

()

P1
normal
VERIFIED WORKSFORME
18 years ago
5 years ago

People

(Reporter: tuukka.tolvanen, Assigned: pierre)

Tracking

({regression})

Trunk
mozilla1.0
x86
Windows 98
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2+) Gecko/20010716
BuildID:    2001071604 trunk, also tested 2001071304

See testcase ... Javascript sets the border color of various elements on page.
Table borders whose width is specified in px or pt fail to change color, but if
width is in em or ex, color does change.

Reproducible: Always
Steps to Reproduce:
1. Go to testcase
2. click on ">>>click here to change colors<<<"

Actual Results:  they don't
Expected Results:  All borders should change color.

If you enable the alert in the testcase, it will show the style.borderColor of
the px table after changing it. It appears to be updating properly.
(Reporter)

Comment 1

18 years ago
Created attachment 42396 [details]
testcase

Comment 2

18 years ago
seeing this in mozilla0.9.2 win32 build

this might be a dup

Comment 3

17 years ago
I think this bug is related to bug 90937. And the testcase given by the 
reporter clearly states the problem.

ccing table people -- this looks like a tables bug

Comment 5

17 years ago
This sounds like a style issue (without investigating). 
(Assignee)

Comment 6

17 years ago
*** Bug 90937 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

17 years ago
- Simplify the testcase to show only the 2 tables "extable" and "pxtable".
- Dump the style contexts.
==> Both contexts are correct and identical.   It must be a table bug.  
Reassigned to HTML Tables.
Assignee: jst → karnaze
Component: DOM Style → HTMLTables
QA Contact: ian → amar
(Assignee)

Comment 8

17 years ago
Created attachment 53551 [details]
dump style context (simplified)

Comment 9

17 years ago
Created attachment 53571 [details]
color log file

Comment 10

17 years ago
Created attachment 53572 [details] [diff] [review]
debug code

Comment 11

17 years ago
I added the debug code (attachment 53572 [details] [diff] [review]) in order to produce the color log
(attachment 53571 [details]) It clearly shows that the table border color used for the
painting does not change. But this is what we get from the style system, so I am
not confident that this is a table bug, for me it looks like a style bug :-)

Comment 12

17 years ago
-->pierre
Assignee: karnaze → pierre
(Assignee)

Comment 13

17 years ago
It is a regression from the rule tree landing (bug 91672).  See also related bug 
103533 that describes a problem where we can no longer change by script the style 
of tables that have a style attribute.
Blocks: 91672
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.9

Updated

17 years ago
Keywords: regression
Moving to Mozilla1.1. Engineers are overloaded with higher priority bugs.
Target Milestone: mozilla0.9.9 → mozilla1.1
Bulk moving from Moz1.1 to future-P1. I will pull from this list when scheduling
work post Mozilla1.0.
Priority: P3 → P1
Target Milestone: mozilla1.1 → Future

Comment 16

17 years ago
Fixed with bug 92868.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Target Milestone: Future → mozilla1.0

Updated

17 years ago
Keywords: nsbeta1+
Re-opening, as the checkin which fixed this bug has been backed out due to
severe regressions (bug 129827).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 18

17 years ago
WFM Windows 2000 build 20020317

Comment 19

17 years ago
WFM using the test case provided. Tested in the March 19th build (2002-03-19-03)
under Windows ME.
Resolving WFM.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 21

17 years ago
 The borders in the given testcase changes colors when I click on ">>>click here
to change colors<<<". Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.