[wasabi] data connection does not work under CT network

RESOLVED INVALID

Status

Firefox OS
General
--
critical
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Peipei Cheng (needinfo if you need my action), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 795930 [details]
adb.log

Device info: ZTE N970
Network: CT network
wasabi build: 20130823061633

The data connection works perfect on a new ZTE N970 android phone. The 3G and 1X appears on the signal bar. And the speed is over 1 MB/second.

Then I flash wasabi build to this device. But the data connection does not work at all on this device.
1. Neither 3G nor 1x appears on the signal bar after I enable data connection and set the network type to CDMA/EVDO.
2. The Phone number under device information is unknown.

Note: I use the same UIM card for the test. And the device is the same. Since android OS works, this should be a problem of Firefox OS.


Please see attached logcat for details.
Severity: normal → critical

Updated

4 years ago
blocking-b2g: --- → koi?

Updated

4 years ago
Blocks: 890828
If the below APN profile is allright, it should be the authType issue mentioned in Bug 901227.

I/Gecko   (  199): -*- RILNetworkInterface[0:1]: Going to set up data connection with APN live.vodafone.com
I/Gecko   (  199): -*- RILNetworkInterface[0:1]: Invalid authType undefined
I/Gecko   (  199): RIL Worker[0]: Received chrome message {"radioTech":6,"apn":"live.vodafone.com","user":"vodafone","passwd":"vodafone","chappap":3,"pdptype":"IP","rilMessageToken":25,"rilMessageType":"setupDataCall"}

...

I/Gecko   (  199): -*- RadioInterface[0]: Received message from worker: {"status":65535,"suggestedRetryTime":-1,"cid":"0","active":0,"type":"","ifname":"","ipaddr":"","dns":"","gw":"","ip":null,"netmask":null,"broadcast":null,"apn":"live.vodafone.com","rilMessageType":"datacallerror","errorMsg":"UnspecifiedError"}
I/Gecko   (  199): -*- RILNetworkInterface[0:1]: Data call error on APN: live.vodafone.com
I/Gecko   (  199): -*- RILNetworkInterface[0:1]: Data call - APN Connection Retry Timer (secs-counter): 515-9
Sorry, there was no authtype from the beginning, so using the default authtype is allright:

I/Gecko   (  199): -*- RadioInterface[0]: 'ril.data.apnSettings' is now [[{"carrier":"Vodafone NL","apn":"live.vodafone.com","user":"vodafone","password":"vodafone","mmsc":"http://mmsc.mms.vodafone.nl","mmsproxy":"192.168.251.150","mmsport":"8799","types":["default","supl","mms"]}]]

Could you help compare the above APN profile with Android's?
Thanks.
The APN for android is "ctnet". I also tried to configure the same APN on FFOS, but the result turn out to be the same as the default APN.
Sorry, I configured the wrong just now. Please ignore above comment 3.

After configuring following APN, 3G appears on the signal bar. But 1X does not show up.

Following is the configuration:

APN:ctnet
Identifier:ctnet@mycdma.cn
Password:vnet.mobi
Auth type:PAP/CHAP
@Jessica, thanks a lot for your help. The problem is the APN profile. I will close this bug as invalid. Thanks again!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID

Updated

4 years ago
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.