Closed Bug 909765 Opened 6 years ago Closed 6 years ago

Make TextureClient and CompositableClient ref counting thread-safe

Categories

(Core :: Graphics: Layers, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26
Tracking Status
firefox25 --- fixed
firefox26 --- fixed

People

(Reporter: nical, Assigned: nical)

Details

(Whiteboard: [qa-])

Attachments

(1 file)

With async video stuff this should have been made thread-safe, my bad.
Comment on attachment 796041 [details] [diff] [review]
Thread-safe ref counting for TextureClient and CompositableClient

Good catch! Looks good to me.
Attachment #796041 - Flags: review?(sotaro.ikeda.g) → review+
Comment on attachment 796041 [details] [diff] [review]
Thread-safe ref counting for TextureClient and CompositableClient

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 858914
User impact if declined: thread-unsafe code, could lead to rare instability.
Testing completed (on m-c, etc.): just landed
Risk to taking this patch (and alternatives if risky): very low risk
String or IDL/UUID changes made by this patch:
Attachment #796041 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/a6006fb455fd
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Attachment #796041 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Assuming no verification needed here. Please add the verifyme keyword and remove the [qa-] whiteboard tag to request verification.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.