Closed Bug 909813 Opened 6 years ago Closed 6 years ago

Input autocomplete popup hover styling broken with Aero

Categories

(Toolkit :: Themes, defect)

25 Branch
All
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla26
Tracking Status
firefox24 --- unaffected
firefox25 + verified
firefox26 --- verified

People

(Reporter: johan.charlez, Assigned: Paenglab)

References

()

Details

(Keywords: regression)

Attachments

(3 files, 2 obsolete files)

See the link for a testcase.

If you open the testcase and type "f" into the input field and then hover one of the options in the autocomplete popup, you will notice that the styling of the hovered item has regressed.

To recreate what you see in the screenshot you most likely need to have Windows Aero enabled.
Component: Theme → Themes
Product: Firefox → Toolkit
Attached patch proposed fix (obsolete) — Splinter Review
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #796210 - Flags: review?(dao)
Comment on attachment 796210 [details] [diff] [review]
proposed fix

>   treechildren::-moz-tree-cell-text(selected, focus) {
>     color: -moz-DialogText;
>   }

I don't remember what ::-moz-tree-cell-text is. Is it irrelevant for .autocomplete-treebody?
https://mxr.mozilla.org/mozilla-central/source/toolkit/themes/windows/global/autocomplete.css#83 uses !important, so no :not(.autocomplete-treebody) in tree-aero.css needed.
(In reply to Richard Marti [:Paenglab] from comment #3)
> https://mxr.mozilla.org/mozilla-central/source/toolkit/themes/windows/global/
> autocomplete.css#83 uses !important, so no :not(.autocomplete-treebody) in
> tree-aero.css needed.

I'd rather not depend on that.
Attached patch proposed fix v2 (obsolete) — Splinter Review
Okay, to be sure I've added the :not(.autocomplete-treebody) to treechildren::-moz-tree-cell-text(selected, focus).
Attachment #796210 - Attachment is obsolete: true
Attachment #796210 - Flags: review?(dao)
Attachment #796230 - Flags: review?(dao)
Comment on attachment 796230 [details] [diff] [review]
proposed fix v2

>   treechildren::-moz-tree-cell-text {
>     padding-bottom: initial;
>     border-color: transparent;
>     background-color: transparent;
>   }

What about this?
(In reply to Dão Gottwald [:dao] from comment #6)
> Comment on attachment 796230 [details] [diff] [review]
> proposed fix v2
> 
> >   treechildren::-moz-tree-cell-text {
> >     padding-bottom: initial;
> >     border-color: transparent;
> >     background-color: transparent;
> >   }
> 
> What about this?

Not really needed as you can see on the screenshot. But to be sure, I'm adding a patch with this addressed :)
Attached patch proposed fix v3Splinter Review
Attachment #796230 - Attachment is obsolete: true
Attachment #796230 - Flags: review?(dao)
Attachment #796621 - Flags: review?(dao)
Attachment #796621 - Flags: review?(dao) → review+
Keywords: checkin-needed
Comment on attachment 796621 [details] [diff] [review]
proposed fix v3

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 855998
User impact if declined: Weird display in autocomplete popup
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): low, where are only css changes
String or IDL/UUID changes made by this patch: no
Attachment #796621 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/e8fc606bab46
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Attachment #796621 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0

Reproduced this issue with Nightly (Build ID: 20130826030203) with steps from comment 0.
Verified as fixed with latest Aurora 25.0a2 (Build ID: 20130910004002) and Nightly 26.0a1 (Build ID: 20130910030254).
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.