ContentDispatchChooser isn't showing anything on links it can't open

RESOLVED FIXED in Firefox 25

Status

()

Firefox for Android
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: wesj, Assigned: wesj)

Tracking

unspecified
Firefox 26
x86
Linux
Points:
---

Firefox Tracking Flags

(firefox24 wontfix, firefox25 fixed, firefox26 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 796141 [details] [diff] [review]
Patch

The multi-locale repacks broke the content dispatch chooser toasts that say "Couldn't find an application to open this link". Fix it!

I also added a logging string when these fail so that its a bit easier to diagnose these reports.
(Assignee)

Comment 1

4 years ago
Comment on attachment 796141 [details] [diff] [review]
Patch

Thankfully, this doesn't need real string changes and we can uplift it!
Attachment #796141 - Flags: review?(mark.finkle)
Comment on attachment 796141 [details] [diff] [review]
Patch

>diff --git a/mobile/android/components/ContentDispatchChooser.js b/mobile/android/components/ContentDispatchChooser.js

>+        Services.console.logStringMessage("Can't open uri " + aURI.spec);

We should not add this since it shows a URL and breaks privacy

>diff --git a/mobile/android/locales/jar.mn b/mobile/android/locales/jar.mn

>   locale/@AB_CD@/browser/payments.properties      (%chrome/payments.properties)
>+  locale/@AB_CD@/browser/handling.properties    (%chrome/handling.properties)

align better

r+ but we really need to remove the log
Attachment #796141 - Attachment is patch: true
Attachment #796141 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 3

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/7fd6c2e59b65
(Assignee)

Comment 4

4 years ago
Comment on attachment 796141 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 792077
User impact if declined: Nothing shown when the user clicks some links
Testing completed (on m-c, etc.): Landed on mc today.
Risk to taking this patch (and alternatives if risky): Low risk. Overwrites some strings, but we've been shipping this localization file for awhile, just not using it. AFAIK, localizers have localized it, but its just never shown to people.
String or IDL/UUID changes made by this patch: This fixes up some configuration files to bundle things correctly. i.e. we're shipping the same strings as always, we're just using the right ones now.
Attachment #796141 - Flags: approval-mozilla-beta?
Attachment #796141 - Flags: approval-mozilla-aurora?
Comment on attachment 796141 [details] [diff] [review]
Patch

Although a nice to have, as long as we are functionally correct I do not want to rush this in our final beta's so approving on aurora only at this time.
Attachment #796141 - Flags: approval-mozilla-beta?
Attachment #796141 - Flags: approval-mozilla-beta-
Attachment #796141 - Flags: approval-mozilla-aurora?
Attachment #796141 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/7fd6c2e59b65
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
https://hg.mozilla.org/releases/mozilla-aurora/rev/c403d63667fe
status-firefox25: --- → fixed
status-firefox26: --- → fixed
status-firefox24: --- → wontfix
You need to log in before you can comment on or make changes to this bug.