Closed Bug 909860 Opened 8 years ago Closed 7 years ago

Enhancement Request: Cleanup on exit

Categories

(Firefox for Android Graveyard :: General, enhancement)

23 Branch
All
Android
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 996028

People

(Reporter: br.renatosilva, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812




Expected results:

It would be really nice if we could configure Firefox to clean up browsing data on exit just like we can do in desktop. Although it may be hard to determine what is an exit on Android, I think it's worth consideration.

Personally, the problem here is that Android sucks in the first place. That said, at least in practice Firefox does show a behavior just like it was "restarted" sometimes. For example, I have seen a previous tab thing similar to desktop's previous session button. Also, when we remove Firefox from recent apps, when we come back again the tabs are not there and it looks like "restarted".

Implementation could be maybe adding a quit button, and then performing the cleanup from there. Or maybe trying to determine a relevant exit event. Either way, something that would dismiss the need for QuitNow and ObliviousSession add-ons.
OS: Windows 7 → Android
Hardware: x86 → All
Severity: normal → enhancement
Summary: Cleanup on exit → Enhancement Request: Cleanup on exit
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 996028
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.