Closed Bug 909879 Opened 6 years ago Closed 6 years ago

[B2G] [Buri] [1.2] [Bluetooth] Unable to pair with other devices, no error message shown

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: ckreinbring, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

Description:
The user is unable to pair to another device via Bluetooth.

Repro Steps:
1) Update Buri to Build ID: 20130827040201
2) Select Settings then Bluetooth
3) Tap Search for Devices and look for a device to pair up with.
4) When an appropriate device appears, tap it and select the Pair button if a confirmation screen appears.
5) Observe the device's behavior as it attempts to pair.

Actual:
The devices fail to pair.  No obvious error message appears.

Expected:
The devices are paired together.

Environmental Variables
Build ID: 20130827040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/e42dce3209da
Gaia: 599214a0f41eece076dc83cd85f5b27f8cfe67f2
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
See attached logcat logs
escalating due to blocking Bluetooth smoketest test cases
blocking-b2g: --- → koi?
Component: Gaia::Bluetooth File Transfer → Bluetooth
Hi,

When did this problem first happen? And can you reproduce the issue with Gecko rev 3b8495731a83 [1] ?

[1] http://hg.mozilla.org/mozilla-central/rev/3b8495731a83
Flags: needinfo?(ckreinbring)
The first day this bug reproduced was today.  See the description for its environmental variables.

The bug did not reproduce on yesterday's 1.2 mozilla RIL.
Environmental Variables
Build ID: 20130826163255
Gecko: http://hg.mozilla.org/mozilla-central/rev/14b1e8c2957e
Gaia: 23343e6ea3cc59c3ab0ac9188aaa657bd11da4fd
Platform Version: 26.0a1

The bug also did not reproduce on Friday's 1.2 mozilla RIL.
Environmental Variables
Build ID: 20130823040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/fb2318875cd4
Gaia: 72d9989f759099632c3d3b8b5335b7d12d969d2f
Platform Version: 26.0a1
ckreinbring: Which devices were you trying to pair? I am using the same build as in Comment 0 and I was able to pair my Macbook Pro with the device, and a Plantronics Bluetooth Headset.
We used other Buri devices to attempt to pair.
(In reply to ckreinbring from comment #5)
> We used other Buri devices to attempt to pair.

I just tested this again today and was able to pair two Buri devices, and share a picture from one to the other.
So was I.  I successfully paired two Buri devices as well as a Buri and a headset.

Build ID: 20130828040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/416075f77249
Gaia: eb48d3682e045c94b650323b5a55898afdf3e3b1
Platform Version: 26.0a1
Flags: needinfo?(ckreinbring)
Recent smoketest reports aren't showing this in the report, which implies this isn't being hit by everyone.
Keywords: smoketest
No longer blocks: b2g-central-dogfood
closed this as it's working for people on newer builds
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Closed: 6 years ago
Resolution: --- → WORKSFORME
Verifying as Worksforme since we are still unable to repro it on Buri 1.2 mozilla RIL.  Attempts to pair devices have been successful.

Build ID: 20130904040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ff96bd19c1c
Gaia: b6c5bf1d24230bfed4a8f680e625fa2175001f82
Platform Version: 26.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.