assertions when viewing unread messages in a newsgroup that I've dowloaded for offline

VERIFIED WORKSFORME

Status

MailNews Core
Networking: NNTP
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

assertions when viewing unread messages in a newsgroup that I've dowloaded for 
offline.

I hope this isn't a wild goose chase.

here's what I did:

read netscape.test on news.mozilla.org
select all, File | Offline | Get Selected Messages

then later (another session) I did View | Messages | Unread.

things seem fine, but I get a ton of assertions:

###!!! ASSERTION: couldn't get header for some reason: 'NS_SUCCEEDED(rv) && 
msgHdr', file c:\builds\mozilla\mailnews\base\src\nsMsgThreadedDBView.cpp, line 
301

msgHdr was null.

here's the stack:

nsMsgThreadedDBView::ListThreadIds(unsigned int * 0x0012bce4, int 1, unsigned 
int * 0x0012b698, int * 0x0012aec8, char * 0x0012b508, int 400, int * 
0x0012bcd8, int * 0x00000000) line 301
nsMsgThreadedDBView::InitThreadedView(int * 0x0012bedc) line 79 + 69 bytes
nsMsgThreadedDBView::Open(nsMsgThreadedDBView * const 0x059bc2b0, nsIMsgFolder 
* 0x053cb5fc, int 18, int 1, int 16, int * 0x0012bedc) line 48
XPTC_InvokeByIndex(nsISupports * 0x059bc2b0, unsigned int 3, unsigned int 5, 
nsXPTCVariant * 0x0012be9c) line 139
XPCWrappedNative::CallMethod(XPCCallContext & {...}, XPCWrappedNative::CallMode 
CALL_METHOD) line 1881 + 42 bytes
XPC_WN_CallMethod(JSContext * 0x03b7a030, JSObject * 0x03ecf1d0, unsigned int 
5, long * 0x03eda84c, long * 0x0012c0d0) line 1252 + 11 bytes
js_Invoke(JSContext * 0x03b7a030, unsigned int 5, unsigned int 0) line 807 + 23 
bytes
js_Interpret(JSContext * 0x03b7a030, long * 0x0012ce70) line 2701 + 15 bytes
js_Invoke(JSContext * 0x03b7a030, unsigned int 1, unsigned int 2) line 824 + 13 
bytes
nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJSClass * const 0x041fed90, 
nsXPCWrappedJS * 0x054b5780, unsigned short 5, const nsXPTMethodInfo * 
0x02cadf40, nsXPTCMiniVariant * 0x0012d3b4) line 1019 + 21 bytes
nsXPCWrappedJS::CallMethod(nsXPCWrappedJS * const 0x054b5780, unsigned short 5, 
const nsXPTMethodInfo * 0x02cadf40, nsXPTCMiniVariant * 0x0012d3b4) line 427
PrepareAndDispatch(nsXPTCStubBase * 0x054b5780, unsigned int 5, unsigned int * 
0x0012d464, unsigned int * 0x0012d454) line 100 + 31 bytes
SharedStub() line 124
XPTC_InvokeByIndex(nsISupports * 0x054b5780, unsigned int 5, unsigned int 1, 
nsXPTCVariant * 0x0012d5e4) line 139
XPCWrappedNative::CallMethod(XPCCallContext & {...}, XPCWrappedNative::CallMode 
CALL_METHOD) line 1881 + 42 bytes
XPC_WN_CallMethod(JSContext * 0x03b7a030, JSObject * 0x03cee010, unsigned int 
1, long * 0x03eda638, long * 0x0012d818) line 1252 + 11 bytes
js_Invoke(JSContext * 0x03b7a030, unsigned int 1, unsigned int 0) line 807 + 23 
bytes
js_Interpret(JSContext * 0x03b7a030, long * 0x0012e5b8) line 2701 + 15 bytes
js_Invoke(JSContext * 0x03b7a030, unsigned int 1, unsigned int 2) line 824 + 13 
bytes
js_InternalInvoke(JSContext * 0x03b7a030, JSObject * 0x03e183c0, long 65113112, 
unsigned int 0, unsigned int 1, long * 0x0012e790, long * 0x0012e6e0) line 896 
+ 20 bytes
JS_CallFunctionValue(JSContext * 0x03b7a030, JSObject * 0x03e183c0, long 
65113112, unsigned int 1, long * 0x0012e790, long * 0x0012e6e0) line 3320 + 31 
bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x03b7a1e0, void * 
0x03e183c0, void * 0x03e18c18, unsigned int 1, void * 0x0012e790, int * 
0x0012e78c, int 0) line 942 + 33 bytes
nsJSEventListener::HandleEvent(nsJSEventListener * const 0x05208920, 
nsIDOMEvent * 0x059bcc44) line 139 + 57 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x05227040, 
nsIDOMEvent * 0x059bcc44, nsIDOMEventTarget * 0x0525af58, unsigned int 8, 
unsigned int 7) line 1161 + 20 bytes
nsEventListenerManager::HandleEvent(nsEventListenerManager * const 0x052582e0, 
nsIPresContext * 0x03b8b270, nsEvent * 0x0012f2b0, nsIDOMEvent * * 0x0012f15c, 
nsIDOMEventTarget * 0x0525af58, unsigned int 7, nsEventStatus * 0x0012f2fc) 
line 2131 + 36 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x0525af50, nsIPresContext * 
0x03b8b270, nsEvent * 0x0012f2b0, nsIDOMEvent * * 0x0012f15c, unsigned int 1, 
nsEventStatus * 0x0012f2fc) line 3633
PresShell::HandleDOMEventWithTarget(PresShell * const 0x03b97b50, nsIContent * 
0x0525af50, nsEvent * 0x0012f2b0, nsEventStatus * 0x0012f2fc) line 5678 + 39 
bytes
nsMenuFrame::Execute() line 1489
nsMenuFrame::HandleEvent(nsMenuFrame * const 0x03e01650, nsIPresContext * 
0x03b8b270, nsGUIEvent * 0x0012f754, nsEventStatus * 0x0012f648) line 459
PresShell::HandleEventInternal(nsEvent * 0x0012f754, nsIView * 0x05926d80, 
unsigned int 1, nsEventStatus * 0x0012f648) line 5646 + 41 bytes
PresShell::HandleEvent(PresShell * const 0x03b97b54, nsIView * 0x05926d80, 
nsGUIEvent * 0x0012f754, nsEventStatus * 0x0012f648, int 0, int & 1) line 5558 
+ 25 bytes
nsView::HandleEvent(nsView * const 0x05926d80, nsGUIEvent * 0x0012f754, 
unsigned int 8, nsEventStatus * 0x0012f648, int 0, int & 1) line 377
nsView::HandleEvent(nsView * const 0x05920630, nsGUIEvent * 0x0012f754, 
unsigned int 8, nsEventStatus * 0x0012f648, int 0, int & 1) line 350
nsView::HandleEvent(nsView * const 0x0591e1f0, nsGUIEvent * 0x0012f754, 
unsigned int 8, nsEventStatus * 0x0012f648, int 0, int & 1) line 350
nsView::HandleEvent(nsView * const 0x03b88820, nsGUIEvent * 0x0012f754, 
unsigned int 28, nsEventStatus * 0x0012f648, int 1, int & 1) line 350
nsViewManager::DispatchEvent(nsViewManager * const 0x03b889c0, nsGUIEvent * 
0x0012f754, nsEventStatus * 0x0012f648) line 2057
HandleEvent(nsGUIEvent * 0x0012f754) line 68
nsWindow::DispatchEvent(nsWindow * const 0x059204f4, nsGUIEvent * 0x0012f754, 
nsEventStatus & nsEventStatus_eIgnore) line 721 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f754) line 742
nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 4241 
+ 21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 
4490
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 1376325, long * 
0x0012fb94) line 3204 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x00100376, unsigned int 514, unsigned int 0, 
long 1376325) line 989 + 27 bytes
USER32! 77e13eb0()
USER32! 77e1401a()
USER32! 77e192da()
nsAppShellService::Run(nsAppShellService * const 0x01122250) line 424
main1(int 3, char * * 0x00485f20, nsISupports * 0x00000000) line 1174 + 32 bytes
main(int 3, char * * 0x00485f20) line 1478 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e87
(Assignee)

Comment 1

17 years ago
I was not able to reproduce this.

Comment 2

17 years ago
I have the same problem on Windows 2000 although I am not downloading for 
offline viewing (I have actually had this problem for many months). This 
happens for me when I open the news server and then click on a newsgroup. I get 
loads of assertions - the number seems to be related to the number of new 
messages in the group.
Component: Mail Window Front End → Networking - News
QA Contact: esther → stephend

Comment 3

16 years ago
*** Bug 98010 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

16 years ago
marking wfm - if anyone still sees this on a trunk build, please re-open.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
I don't see the assert either; and I built debug just for you, spitzer!

verified worksforme

- hammer
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.