Closed Bug 909940 Opened 6 years ago Closed 6 years ago

Default keyboard on HTC One only swipes first word in awesome screen

Categories

(Firefox for Android :: Keyboards and IME, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 27
Tracking Status
firefox24 --- unaffected
firefox25 + verified
firefox26 + verified
firefox27 --- verified
fennec 25+ ---

People

(Reporter: mjrosenb, Assigned: jchen)

References

Details

Attachments

(2 files)

When I'm going to search for something, after opening a new tab, I can swipe the first word of my search just fine.  Then I hit space to get a new word, and go to swipe a second word, I don't get the trail of where I swiped, each letter highlights individually, and when I lift my finger, I only get the last character that I swiped.  After this, everything seems to work normally.  IIRC, the htc one is the first phone to use sense 5.0.
Assignee: nobody → nchen
OS: Linux → Android
Hardware: x86_64 → All
Ok, small update.  previously, I was not sure if this was actually a bug with fennec, or it is just the sense keyboard being broken.  It works with the current beta, so this is a regression in functionality.
Can repo on a HTC One X+ running sense 5.

Steps:
* Make sure Firefox is not running
* Start Firefox
* Tap the awesome screen
* Swipe a word
* Press space
* Swipe a second word

Note skipping the space button step allows you to enter more than one word without issue. You can also repo in an already running Firefox by opening a new tab and following the steps from the 3rd bullet.

Unsure if 25 is affected. Will need to use MOZ_LINKER_ONDEMAND=0 environment variable to find a regression range due to bug 907957.
I tried both of these, and they both seem to exhibit the broken behavior (I am only 99.9% certain that I actually tried both builds)
Just tried both of the latest builds, and neither one worked.
2013-07-15 good - ff0a372e3170
2013-07-16 crash
2013-07-19 crash
2013-07-22 crash
2013-07-23 crash
2013-07-24 bad - 2983ca6d4d1a

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ff0a372e3170&tochange=2983ca6d4d1a

bug 886508
bug 895236
bug 891316

All seem like candidates during that range.
tracking-fennec: --- → ?
tracking-fennec: ? → 25+
Not sure if this is a separate issue, but following the STR on fennec-23 and fennec-24 produces "Unfortunately, HTC Sense Input has stopped".  I don't know if I've seen it in portrait mode, but I have certainly seen it in landscape mode.
Here's a build with URL/search detection disabled for HTC keyboards, http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/nchen@mozilla.com-a4b54f9f77b1/try-android/fennec-26.0a1.en-US.android-arm.apk
Flags: needinfo?(mrosenberg)
ok, just tried that one on my htc one, and it seems to work correctly. (the crashes were a tad non-deterministic before)
Flags: needinfo?(mrosenberg)
Duplicate of this bug: 919634
The build in comment 9 also fixes bug 919634.
The HTC keyboard is prone to crashing and misbehaving in general when we switch its type dynamically. We should just disable that for now.
Attachment #808733 - Flags: review?(cpeterson)
Comment on attachment 808733 [details] [diff] [review]
Disable updating the URL bar type for HTC keyboards (v1)

Review of attachment 808733 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #808733 - Flags: review?(cpeterson) → review+
https://hg.mozilla.org/mozilla-central/rev/80613c46eae2
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
Any chance of this being uplifted at all, or are we just going to have to wait until January 21st for the fix?

Additional Information:
This affects any device using the HTC Sense 4+ or higher (maybe 4.0 and higher) keyboard.  This has been in issue/annoyance for a while, but I just never bothered to file a bug report on it.  It has also existed in several (if not all) release builds.
This is tracking 25+ so I would imagine we can get this into Firefox Beta shortly assuming a low risk evaluation assessment.
Flags: needinfo?(nchen)
Comment on attachment 808733 [details] [diff] [review]
Disable updating the URL bar type for HTC keyboards (v1)

[Approval Request Comment]

Bug caused by (feature/regressing bug #): N/A

User impact if declined: Keyboard can misbehave and/or crash on HTC devices when using the URL bar

Testing completed (on m-c, etc.): m-c, locally

Risk to taking this patch (and alternatives if risky): Very small; only affects HTC devices

String or IDL/UUID changes made by this patch: None
Attachment #808733 - Flags: approval-mozilla-beta?
Attachment #808733 - Flags: approval-mozilla-aurora?
Flags: needinfo?(nchen)
Comment on attachment 808733 [details] [diff] [review]
Disable updating the URL bar type for HTC keyboards (v1)

I hate taking input changes in the last couple of weeks of a release, but we'll make an exception here to prevent a new regression for HTC users.
Attachment #808733 - Flags: approval-mozilla-beta?
Attachment #808733 - Flags: approval-mozilla-beta+
Attachment #808733 - Flags: approval-mozilla-aurora?
Attachment #808733 - Flags: approval-mozilla-aurora+
And as a reminder, regressions of this nature should be nominated for tracking-firefox
(In reply to Alex Keybl [:akeybl] from comment #21)
> And as a reminder, regressions of this nature should be nominated for
> tracking-firefox

based on comment 17, I don't know that this is a regression
https://hg.mozilla.org/releases/mozilla-aurora/rev/77e2a30105df

Needs a branch-specific patch for the beta uplift.
Flags: needinfo?(nchen)
Attached patch Patch for BetaSplinter Review
Attachment #814935 - Flags: review+
Attachment #814935 - Flags: checkin?
Flags: needinfo?(nchen)
Attachment #814935 - Flags: checkin? → checkin+
Flags: needinfo?(aaron.train)
Keywords: verifyme
Status: RESOLVED → VERIFIED
Flags: needinfo?(aaron.train)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.