java.lang.arrayindexoutofboundsexception

RESOLVED WONTFIX

Status

Core Graveyard
Java: OJI
RESOLVED WONTFIX
17 years ago
7 years ago

People

(Reporter: rechnung, Assigned: Terry Noyes)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When entering URL www.lfd.niedersachsen.de you get an java array out of bounds
error. Works with NS 4.77 or Opera

Comment 1

17 years ago
* use the bugzilla helper
http://www.mozilla.org/quality/help/bug-form.html
* bug reporting guidelines 
http://www.mozilla.org/quality/bug-writing-guidelines.html
* include at least buildid and steps to reproduce
* clearly indicate JavaScript vs. Java and the location where errors appear 
(statusbar, js console, java console, text console, alert message, printer...)
Component: Browser-General → URL Bar
There is no java on the page.  I see no JS "array our of bounds" errors on the
page either.

Why is this URL bar?
Comments from reporter:

the errormessage (just tried it on an imac and a cube, both running 
OS9.1 at 1407 CEDT) is java.lang.arrayindexoutofboundsexception 0>=0.

--------------------------------------
Over to OJI
Assignee: asa → edburns
Component: URL Bar → OJI
QA Contact: doronr → shrir

Comment 4

17 years ago
Although I can not reproduce it at the URL, I get the same errors at
http://www.bcn.com.br/ , and by submitting stream speed from preferences in the
pop up window that is brought up when you click to watch video at
http://www.pbs.org/weta/washingtonweek/video/ . 
Summary: java array out of bounds → java.lang.arrayindexoutofboundsexception

Comment 5

17 years ago
Mac, re-assigning to Terry.
Assignee: edburns → tnoyes

Comment 6

17 years ago
*** Bug 89367 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Confirmed under Mac/2001071903. URL reported is incorrect; the actual URL exhibiting 
the problem is [http://www.lfd.niedersachsen.de/service/service_selbstt.html].
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

17 years ago
Created attachment 44522 [details]
Minimalized HTML containing problem APPLET.

Comment 9

17 years ago
SPAM: reassigning all OJI bugs to new OJI QA, pmac ( 227 bugs)
QA Contact: shrir → pmac

Comment 10

17 years ago
I'm encountering this problem on the purchase pages of ibill.com.  This is
significant, as iBill provides turnkey ecommerce services to a large number of
websites world-wide; presumably anything powered by iBill has this problem. 
They're doing something weird with Java for verification purposes, the code
itself is fairly new from what I can tell.  My browsers just recently began
enabling Java on loading the page, and some of the Mozilla variants I mentioned
below used to have no trouble.  

To recreate the bug, try to purchase anything from an ecommerce site that uses
iBill.  Or, scroll to the bottom of this "sample" page and press any "view
example" button.

http://www.ibill.com/Support/Setup/creditcard/ConfigureHelloPages.cfm

Any example should generate the error.  I see
"java.lang.arrayindexoutofboundsexception 0 >= 0" as a dialogue box that appears
twice.  The box appears after the window has rendered.  I cannot confirm if the
page works properly for a purchase after the error, but I would suspect it to.

This is happening on 20001091408, and 2001082708, and .93 proper, as well as
Netscape 6.1.  I'm on Mac OS 9.1 -- could this be a Mac OS (Macintosh Runtime
for Java) related bug?  

Comment 11

16 years ago
I'm seeing this on Mozilla build 2001112011; Mac OS 9

Comment 12

16 years ago
*** Bug 106597 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
URL from bug 106597:
https://dag.ua.edu/dn/indexstudent.html

This is very annoying as this system would allow me to register for classes over
the Internet rather than by telephone.

CC'ing Patrick Beard as he was the assignee for bug 106597 and seems to be the
King of Java on the Mac.  :-)

Comment 14

16 years ago
I see this problem repeatedly (Mac OS 9.2.2).  But it seems to happen only
when visiting SSL sites.  Applets work fine when visiting normal HTTP sites.

Updated

16 years ago
QA Contact: pmac → petersen

Comment 15

15 years ago
This is the issue with Mac OS 9.2.x/MRJ 2.2.x/NS 7.x, when applet is attempted 
to download on SSL. NS 7 on http/Non-SSL works fine. Other browsers IE 5.1 and 
NS 4.79 work fine on SSL.

The exact error shown is:

java.lang.arrayIndexOutOfBoundsException
0>=0

Above exception is shown twice in a modal dialog. And applet fails to download 
on SSL.
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
I cannot confirm this behaviour in MacOS X with a recent build.
Because we are not working on anything dealing with old Mac since 1.3.1 anymore,
I mark this "WONTFIX".
In case that it reoccurs in MacOS X, please file a new bug.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
I cannot confirm this behaviour in MacOS X with a recent build.
Because we are not working on anything dealing with old Mac since 1.3.1 anymore,
I mark this "WONTFIX".
In case that it reoccurs in MacOS X, please file a new bug.

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.