If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[zffos1.1][P1][Language]the default language is English

RESOLVED INVALID

Status

Firefox OS
Gaia::First Time Experience
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: FangChen, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Reporter)

Description

4 years ago
Built ID 20130823171628
Device: Ikura
QC RIL version: "ro.build.firmware_revision=V1.01.00.01.019.180"
gaia commit: 4916f82 Merge branch 'zte/ics_strawberry_cdr' of ssh://10.67.16.41:29418/quic/lf/releases/gaia into ics_strawberry_cdr
gecko commit: a1c2bb0 ZRL modify ACCEPT Http head for MMS

    A.- Overview Description (technical background, concise explanation of the bug):
    
    the default language is English
    ________________________________________________________________________________
    B.- Steps to Reproduce (initial conditions, required resources, step by step instructions to reproduce):
    
    1.- Turn the DuT On with a SIM Card
2.- Go to Settings, Device Information, More Information
3.- Select Reset the phone
4.- Check the the Language offered in the starting configuration
    ________________________________________________________________________________
    C.- Actual Result (current bad behaviour that is reported as a bug):
    The DuT is in english language when offer the language preferred. 
    
    ________________________________________________________________________________
    D.- Expected Result (correct behaviour wished):
    
    The DuT must be in spanish language when is factory reset default. 
    ________________________________________________________________________________
Not so sure if this is a bug. 

If we perform a reset, any settings information about the language set will be lost.

Fernando, do you see any problem with this?
Flags: needinfo?(fernando.campo)
(Reporter)

Comment 2

4 years ago
Hi the issues means when you start the phone at the first time after reset the phone,the language should be Spanish,because the phone will sell to the region where speak spanish

Updated

4 years ago
blocking-b2g: --- → -
Well, if the original language of the build was Spanish, and it was shown properly on during the first time the phone was turned on, and after the phone was used a factory reset was made, Spanish should be the default again.

I'm not familiar with the factory reset process, any ideas?
Flags: needinfo?(fernando.campo)
Hi all,
After checking the code, during the FTU, we are checking 'language.current' from settings.json for updating the list of languages. However this param could be updated during the user-interaction with the device (we could change the language through Settings App for example). We could create a new var called 'language.default', which will be retrieved when performing a reset, making 'language.current' equal to 'language.default'.
This 'language.default' should be set during the BUILD process (for example for Spain 'es-ES' would be the default one).
FangChen, Wdyt?
Flags: needinfo?(fang.chen1)
(Reporter)

Comment 5

4 years ago
pls my colleague check to see if we can modify the issue
Flags: needinfo?(fang.chen1)

Comment 6

4 years ago
Hi FangChen,
  This bug has been fixed in today's version, you can verify it then.
FangChen, could you check if it is fixed? Thanks! Probably is an issue of v1.0 or v1.1, and now it's uplifted.
(Reporter)

Comment 8

4 years ago
the issue has been modified now,thank you
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.