[zffos1.1][P3][USSD]USSD commands does not work

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: fang.chen1, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

Attachments

(1 attachment)

1.08 MB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Built ID 20130823171628
Device: Ikura
QC RIL version: "ro.build.firmware_revision=V1.01.00.01.019.180"
gaia commit: 4916f82 Merge branch 'zte/ics_strawberry_cdr' of ssh://10.67.16.41:29418/quic/lf/releases/gaia into ics_strawberry_cdr
gecko commit: a1c2bb0 ZRL modify ACCEPT Http head for MMS

  A.- Overview Description (technical background, concise explanation of the bug):
    USSD commands does not work
    
    ________________________________________________________________________________
    B.- Steps to Reproduce (initial conditions, required resources, step by step instructions to reproduce):

    1. Dial and USSD command to activate a suplementary services, for example  *43# to activate waiting calls
    2. Check the behaviour
    
    ________________________________________________________________________________
    C.- Actual Result (current bad behaviour that is reported as a bug):
    
    The command is recognized as a number and the phone make a call
    ________________________________________________________________________________
    D.- Expected Result (correct behaviour wished):
    
    The phone must manage these commands as USSD, and activate/deactivate the Suplementary services requested
Hi, 

This is a critical issue, blocking for certifications. Nominated to leo?
blocking-b2g: --- → leo?
Is there any message shown in the screen?

Can you provide a logcat with RIL information, please?

Which MMI codes are failing? Did you only tried *43# (Call waiting)?
Flags: needinfo?(fang.chen1)
(Reporter)

Comment 3

5 years ago
actually many ussd command cannot work on this sw,we are considering the problem is the RIL of Qualcomm
QC RIL version: "ro.build.firmware_revision=V1.01.00.01.019.180"
Flags: needinfo?(fang.chen1)

Comment 4

5 years ago
Please help to check with qualcomm first
Flags: needinfo?(fang.chen1)

Comment 5

5 years ago
Created attachment 797114 [details]
USSD logs
Blocking as this is a cert Blocker but it may end up as a partner issue.
blocking-b2g: leo? → leo+
(Reporter)

Comment 7

5 years ago
the log has been supplied
Flags: needinfo?(fang.chen1)

Comment 8

5 years ago
Hi Fangchen,
  we are prearing the new build to fix this bug today, you can verify this bug then.
Fangchen,

Did you get a chance to verify with the new build? Is the issue still seen?
Flags: needinfo?(fang.chen1)
(Reporter)

Comment 10

5 years ago
it seemed that the issue had been modified
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(fang.chen1)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.