[B2G][Contacts]When click "message" button for facebook a contact, it prompt this contact is not existed.

RESOLVED FIXED in Firefox OS v1.1hd

Status

Firefox OS
Gaia::Contacts
P2
blocker
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: lecky, Assigned: Jose Manuel Cantera)

Tracking

unspecified
1.2 C2(Oct11)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed, b2g-v1.2 fixed)

Details

(Whiteboard: NPTB, burirun1, burirun2)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 796477 [details]
screenshot for error

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Tablet PC 2.0)

Steps to reproduce:

1. import Facebook contacts.
2. select a facebook contact and click the "message" button.


Actual results:

1. It displays that the contact is not exitsed(see in attachment).


Expected results:

1. go to the UI of edit message.
Related to bug 907740
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?
(Reporter)

Updated

5 years ago
Severity: normal → blocker
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Priority: -- → P2
Resolution: --- → WONTFIX
(Reporter)

Comment 2

5 years ago
This is a bug, if the Facebook message feature is not support, is it better to remove this feature?

Thanks!
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → ASSIGNED
blocking-b2g: hd? → leo?
Ever confirmed: true
QA Contact: jmcf
(Assignee)

Comment 3

5 years ago
I can conform this is happening now. We were implementing this feature using a hack that has stopped working. The problem is that Facdebook still is not supporting the send message dialog on mobile. 

We are going to get in touch with Facebook in order to try to find a solution or other workaround.
Whiteboard: NPTB
(Assignee)

Updated

5 years ago
Assignee: nobody → jmcf
QA Contact: jmcf

Comment 4

5 years ago
Ni? Harald as he may have some insight on our communications with Facebook about this. Harald, please remove the flag or reassign as appropriate.
Flags: needinfo?(hkirschner)
(Assignee)

Comment 5

5 years ago
I have just sent a private email to Harald attaching the email sent to Facebook yesterday.

thanks

Updated

5 years ago
Whiteboard: NPTB → NPOTB

Updated

5 years ago
Whiteboard: NPOTB → [NPOTB]
Awaiting Herald's comment to proceed here.
Whiteboard: [NPOTB] → NPTB
(Assignee)

Updated

5 years ago
Summary: [B2G][Helix][Contacts][wangchao]When click "message" button for facebook a contact, it prompt this contact is not existed. → [B2G][Contacts]When click "message" button for facebook a contact, it prompt this contact is not existed.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 914460
leo plus as regression issue and user impact seems high
blocking-b2g: leo? → leo+
Facebook is contacted and escalating. Last contact was today.
Flags: needinfo?(hkirschner)
Harald,

SO this is not an issue any more?
Flags: needinfo?(hkirschner)
(Assignee)

Comment 11

5 years ago
it is still an issue, until FB announces they have an alternative URL ready for sending messages. When that is ready we will have to submit a small patch in order to tweak our app to comply with the new URL used for sending messages. So this bug has to remain open
(Assignee)

Updated

5 years ago
Flags: needinfo?(hkirschner)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 917068
Minus for now.

Please re-nom once the FB announcement is done.
blocking-b2g: leo+ → -
Whiteboard: NPTB → NPTB, burirun1

Updated

5 years ago
Blocks: 921979
(Assignee)

Comment 14

5 years ago
Created attachment 812991 [details]
12604.html
Attachment #812991 - Flags: review?(crdlc)
Comment on attachment 812991 [details]
12604.html

Thanks a lot
Attachment #812991 - Flags: review?(crdlc) → review+
(Assignee)

Comment 16

5 years ago
https://github.com/mozilla-b2g/gaia/commit/d1deec8d52ce46f95cf398b333926e5cbf7ae0b0

This should be leo+ at least and for sure go to koi as well. 

thanks
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
blocking-b2g: - → leo?

Updated

5 years ago
status-b2g18: --- → affected
status-b2g-v1.2: --- → affected

Updated

5 years ago
Target Milestone: --- → 1.2 QE1(Oct11)

Updated

5 years ago
Whiteboard: NPTB, burirun1 → NPTB, burirun1, burirun2
(Assignee)

Updated

5 years ago
Duplicate of this bug: 924316

Comment 18

5 years ago
Dear Jose, 

Because it's carrier blocking issue, can you land the patch to V1 train ASAP?
Flags: needinfo?(jmcf)
(Assignee)

Comment 19

5 years ago
Hi,

John Ford is responsible for uplifting.

thanks
Flags: needinfo?(jmcf) → needinfo?(jhford)
(In reply to Jack Liu from comment #18)
> Dear Jose, 
> 
> Because it's carrier blocking issue, can you land the patch to V1 train ASAP?

We need a leo+ to grant the ability to land on v1-train.

Let me followup with release management over email to get someone to triage this bug as soon as possible.
This is a hard blocker for Facebook that prevent sending a message to the Facebook contact.
blocking-b2g: leo? → leo+
[v1.2 3a57f63]
[v1-train 680f3b8]
Flags: needinfo?(jhford)
v1.1.0hd: 680f3b86b1e4ff1411ece6ba397b8b0e56b4b31c
status-b2g-v1.1hd: --- → fixed
status-b2g18: affected → fixed
status-b2g-v1.2: affected → fixed
You need to log in before you can comment on or make changes to this bug.