[Buri][REG][STK]should display the default text when execute get input command with default text parameter

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: frsela)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed, b2g-v1.2 fixed)

Details

(Whiteboard: [u=commsapps-user c=stk p=0])

Attachments

(6 attachments)

(Reporter)

Description

5 years ago
Mozilla build ID:20130817041203
 
 
 DEFECT DESCRIPTION:
 [REG][STK]should display the default text when execute get input command with default text parameter
 
  REPRODUCING PROCEDURES:
    1. Load one simulated SIM card which can send "get input" command.
    2. Run case STM03009-> select any item in the list, the prompt message display the text string in the input box ,not the default text string,see the snapshot.--->KO
 
 
  EXPECTED BEHAVIOUR:
 if the get input command with text string and default text string, it should display the default text string in the input box.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 796540 [details]
QXDM log on SW177_1
(Reporter)

Comment 3

5 years ago
Clone from brother
(Reporter)

Comment 4

5 years ago
Created attachment 796541 [details]
ADB log on SW177+GD
(Reporter)

Comment 5

5 years ago
Clone from brother
(Reporter)

Comment 6

5 years ago
Created attachment 796547 [details]
snapshot
(Reporter)

Comment 7

5 years ago
Clone from brother
(Reporter)

Comment 8

5 years ago
Created attachment 796549 [details]
ADB log on SW177
(Reporter)

Comment 9

5 years ago
Clone from brother
(Reporter)

Comment 10

5 years ago
Created attachment 796550 [details]
ADB log on SW177_2

Updated

5 years ago
blocking-b2g: --- → leo?
not sure what the default string in the test box should be. Please clearly state what default string is expected.
Flags: needinfo?(sync-1)

Comment 12

5 years ago
(In reply to Preeti Raghunath(:Preeti) from comment #11)
> not sure what the default string in the test box should be. Please clearly
> state what default string is expected.


this pr is caused for options.maxLength is invalid;

we find the Mozilla build ID:20130826041201 has add the patch:

// Workaround. See bug #818270. Followup: #895314
       setTimeout(function workaround_bug818270() {
         self.icc_input_box.maxLength = options.maxLength;
       });
we will check the patch;

Updated

5 years ago
Flags: needinfo?(sync-1)
Please renom if the work around does not work well and this is a true blocker with how it may impact a user
blocking-b2g: leo? → -

Comment 14

5 years ago
the patch in commont 11, is not ok;
(Reporter)

Updated

5 years ago
blocking-b2g: - → leo?
(Reporter)

Comment 15

5 years ago
this is the mozilla patch:
 
 http://gerrit.tcl-ta.com:8081/#patch,sidebyside,111946,1,apps/system/js/icc.js
 please help to check in 17B;

Comment 16

5 years ago
Dear bbajaj:
  the patch in 818270 is not ok.
Flags: needinfo?(bbajaj)
(In reply to sync-1 from comment #15)
> this is the mozilla patch:
>  
>  http://gerrit.tcl-ta.com:8081/#patch,sidebyside,111946,1,apps/system/js/icc.
> js
>  please help to check in 17B;

This doesn't appear to be externally-accessible:

$ host gerrit.tcl-ta.com
Host gerrit.tcl-ta.com not found: 3(NXDOMAIN)

Fernando, can you take another stab at a workaround since it seems the timeout you added to work around bug 818270 isn't working (comment #16).  Thanks.
Assignee: nobody → frsela
blocking-b2g: leo? → leo+

Updated

5 years ago
Flags: needinfo?(bbajaj)

Comment 18

5 years ago
Dear frsela@tid.es:
Is there any progress??

the timeout patch for this pr is not ok.
Flags: needinfo?(frsela)
(In reply to buri.blff from comment #18)
> Dear frsela@tid.es:
> Is there any progress??
> 
> the timeout patch for this pr is not ok.

Assigned to me (first notice) on friday. Working on it this week
Flags: needinfo?(frsela)

Updated

5 years ago
Whiteboard: [u=commsapps-user c=stk p=0]
Created attachment 808560 [details]
Set default value to the input box

Is the same issue as bug #818270

This fix is a workaround. Followup: #895314
Attachment #808560 - Flags: review?(timdream)

Comment 21

5 years ago
(In reply to Fernando R. Sela (no CC, needinfo please) [:frsela] from comment #20)
> Created attachment 808560 [details]
> Set default value to the input box
> 
> Is the same issue as bug #818270
> 
> This fix is a workaround. Followup: #895314

yes, set the input.maxlength second time dosen't work.

Comment 22

5 years ago
this pr is blocked for set the input.maxlength second time dosen't work.

Comment 23

5 years ago
And the the timeout patch to workaround for this pr is not ok.
No longer blocks: 893614
Depends on: 818270
Comment on attachment 808560 [details]
Set default value to the input box

Sorry for keeping you waiting.
Attachment #808560 - Flags: review?(timdream) → review+

Comment 25

5 years ago
Dear frsela@tid.es:
   Dose setting input.value will affect the input.maxLength for second time??

Comment 26

5 years ago
sorry, what i want to says: 
   Dose setting input.value will make the input.maxLength work well when input.maxLength is changed for second time??

Comment 27

5 years ago
sorry, what i want to say is as follow: 
   Dose setting input.value will make the input.maxLength work well when input.maxLength is changed for second time??
(In reply to buri.blff from comment #27)
> sorry, what i want to say is as follow: 
>    Dose setting input.value will make the input.maxLength work well when
> input.maxLength is changed for second time??

Hi,

The short answer is Yes, it should ;)

In all my test, with this workaround is working perfect in the device.

I think in your case can fail because the testing suite... can your tests *delay* the screen refresh? if your test do that, a race condition can affect this.

Another way is investigate the use of MozAfterPaint [1] but not sure if it's implemented in B2G

[1] https://developer.mozilla.org/en-US/docs/Web/Reference/Events/MozAfterPaint
Landed: https://github.com/mozilla-b2g/gaia/commit/b15ca7b6a895035b67cc593af926dfb9e701a027
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 30

5 years ago
Dear frsela@tid.es:
   this patch is not ok for us.

Comment 31

5 years ago
We don't find this pr on v1.0.1
Uplifted b15ca7b6a895035b67cc593af926dfb9e701a027 to:
v1-train: 05bca4a0c654a86b1b149131cfc96d62ed855b1d
v1.2: 9d54ad9f070183750c884c5cac25987ce3608792
status-b2g18: --- → fixed
status-b2g-v1.2: --- → fixed
v1.1.0hd: 05bca4a0c654a86b1b149131cfc96d62ed855b1d
status-b2g-v1.1hd: --- → fixed
You need to log in before you can comment on or make changes to this bug.