Closed Bug 910155 Opened 8 years ago Closed 8 years ago

Rule view does not keep changed rules marked after inspecting other nodes

Categories

(DevTools :: Inspector, defect)

x86
All
defect
Not set
normal

Tracking

(firefox25 wontfix, firefox26 fixed)

RESOLVED FIXED
Firefox 26
Tracking Status
firefox25 --- wontfix
firefox26 --- fixed

People

(Reporter: paul, Assigned: miker)

References

Details

Attachments

(1 file, 2 obsolete files)

No description provided.
Assignee: nobody → mratcliffe
I originally implemented this in bug 733747. We removed it because we had multiple toolboxes but it should be simple to resurrect.
Status: NEW → ASSIGNED
I also tidied a little.
Comment on attachment 797277 [details] [diff] [review]
reintroduce-rule-view-store-910155.patch

Needs test
Attachment #797277 - Flags: review?(paul)
Attached patch patch v2 (obsolete) — Splinter Review
So, I have tidied other stuff a little 'cos... well, just 'cos.

This is way simpler now and it actually works, which is an added bonus.
Attachment #797277 - Attachment is obsolete: true
Attachment #797734 - Flags: review?(dcamp)
Summary: Re-introduce store in the ruleview → Rule view does not keep changed rules marked after inspecting other nodes
Attached patch Patch v3Splinter Review
Attachment #797734 - Attachment is obsolete: true
Attachment #797734 - Flags: review?(dcamp)
Attachment #797735 - Flags: review?(dcamp)
Comment on attachment 797735 [details] [diff] [review]
Patch v3

Review of attachment 797735 [details] [diff] [review]:
-----------------------------------------------------------------

The mixed in whitespace/formatting changes made this tougher to review, but I'm happy they're done.
Attachment #797735 - Flags: review?(dcamp) → review+
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/52d436a29df0
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Blocks: 894344
Comment on attachment 797735 [details] [diff] [review]
Patch v3

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Any change in the rule view is lost
Testing completed (on m-c, etc.): since fx26
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #797735 - Flags: approval-mozilla-beta?
Attachment #797735 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Doesn't apply to beta at all. Please post a branch-specific patch for uplift.
Flags: needinfo?(mratcliffe)
Landing this in 25 would be too high cost for only a little gain and could result in new bugs as it would require remoting part of the inspector.
Flags: needinfo?(mratcliffe)
Why was approval requested in comment 10 then?
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #13)
> Why was approval requested in comment 10 then?

Paul probably didn't realize that this was fixed after the rule view was remoted.
Attachment #797735 - Flags: approval-mozilla-beta+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.