All users were logged out of Bugzilla on October 13th, 2018

ebay.com - Cannot post ebay auction. - document.SelectorForm.StoreDeptId has no properties

RESOLVED FIXED in May

Status

P1
normal
RESOLVED FIXED
18 years ago
4 years ago

People

(Reporter: wd, Assigned: bc)

Tracking

({top100})

unspecified
top100

Details

(Whiteboard: [SYNTAX-HTML][FEP][MISSING-FORM][retest], URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2+) Gecko/20010715
BuildID:    2001071508

When I clicked Continue to preview a new ebay auction I was posting, nothing
happened.   When I went to the Javascript Console, I saw:

Error: document.SelectorForm.StoreDeptId has no properties
Source File: http://cgi5.ebay.com/aw-cgi/eBayISAPI.dll
Line: 4254

Reproducible: Always
Steps to Reproduce:
1.Preview a new Auction you are about to post on ebay
2.
3.

Actual Results:  Continue button doesn't work

Expected Results:  Works
could you attach the source of the page in question?  The URL you give just
produces an error page.....
(Reporter)

Comment 2

18 years ago
Created attachment 42515 [details]
The page in Question -- [Continue] does nothing
This works in NS 4.x???  The page looks like this (lots of stuff removed):

<form name="SelectorForm">
</form>

<form name="ListItemForSale">
<input name="StoreDeptId">
</form>

So naturally document.SelectorForm.StoreDeptId, not existing, has no proprties.

Over to evangelism.
Assignee: rogerl → bclary
Component: Javascript Engine → Evangelism
OS: Windows 98 → All
QA Contact: pschwartau → zach
Hardware: PC → All
Whiteboard: [SYNTAX-HTML]
(Assignee)

Updated

18 years ago
Priority: -- → P1
(Reporter)

Comment 4

18 years ago
The attached page works in IE and NS 4.x.   Just click "Continue".    (no need
to fill out any info or anything)

Comment 5

18 years ago
This one is interesting. Here is the pattern of <FORM>'s Boris mentions.
I copied the HTML locally, and have included the line numbers:


4530
<form method="post" name="SelectorForm">

4833
document.write('</form>');


4972
document.write('<form method=\"post\" name=\"ListItemForSale\"                       
action=\"http://cgi5.ebay.com/aw-cgi/eBayISAPI.dll\">');

5100
<input type="hidden" name="StoreDeptId" value="">

6255
</form>


6256
<form name="ClearListItemForSale" onSubmit="clearWells();" method="get"       
action="http://cgi5.ebay.com/aw-cgi/eBayISAPI.dll">

6262
</form>

Comment 6

18 years ago
Created attachment 42584 [details]
Reduced HTML testcase -

Comment 7

18 years ago
If you run the reduced HTML testcase, you will see the same result 
in all three browsers: IE4.7, NN4.7, and Mozilla/N6. The DOM element
document.SelectorForm.StoreDeptId does not exist; the element "StoreDeptId" 
is located on the "ListItemForSale" form instead. 

This explains the error in the Mozilla JavaScript Console reported above:

     Error: document.SelectorForm.StoreDeptId has no properties


As to why the ebay page still functions in the earlier browsers, this 
important point may explain it: 

Mozilla differs from Nav4 and earlier because it catches syntax errors 
before binding functions, or even compiling code for them.  This is within 
the spec (ECMA-262). Any syntax error causes execution to stop. Because of the 
ECMA standard, any malformed syntax means we can't generate code, because we 
generate the code from a complete parse tree.

That's why in Mozilla, a syntax error can cause execution to halt,
whereas in 4.x, execution would only stop if the syntax error was 
actually accessed at runtime - 
(Assignee)

Comment 8

18 years ago
Marking as a candidate for ffrequently encountered problem. Phil, thanks for the
explanation of the differences between NN4 and Mozilla on how they handle
parsing / executing JS. That helps a lot.
Whiteboard: [SYNTAX-HTML] → [SYNTAX-HTML][FEP]
*** Bug 91236 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

18 years ago
I have contacted someone who may be able to help us with Ebay. I will update as
more information becomes available.
Status: NEW → ASSIGNED
*** Bug 91787 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
(Assignee)

Comment 13

17 years ago
follow up with these sites by 0.9.5
Target Milestone: --- → mozilla0.9.5
(Assignee)

Updated

17 years ago
Summary: Cannot post ebay auction. - document.SelectorForm.StoreDeptId has no properties → ebay.com - Cannot post ebay auction. - document.SelectorForm.StoreDeptId has no properties

Comment 14

17 years ago
*** Bug 97244 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

17 years ago
-> 0.9.6, need to follow up on these asap
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 16

17 years ago
I checked this over the weekend, and it's still busted. 
*** Bug 103595 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

17 years ago
Keywords: top100
*** Bug 107327 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
I've verified on 9.4 milestone (Win 98) and it's still busted...very irritating
as I had already filled out the whole form in Ebay, hit continue and then
Nothing! grr!

Recommended: add "form" to the summary so that searching on "form" brings up
this bug. I had to search on "ebay" to find it. 
(Assignee)

Comment 20

17 years ago
ok, clearing milestone to get back on the radar.
Whiteboard: [SYNTAX-HTML][FEP] → [SYNTAX-HTML][FEP][MISSING-FORM]
Target Milestone: Nov → ---

Comment 21

17 years ago
Perhaps finding other browsers which have this problem will encourage eBay to
remedy the problem.  Last ditch, break ECMA-262 compliance?!?

Comment 22

17 years ago
should we set this back to NEW to get this back on the radar as well, 
reassign it to the owner and qa contact of selected component if you 
agree with me.

Comment 23

17 years ago
http://cgi4.ebay.com/aw-cgi/eBayISAPI.dll?SSLRegisterFromCountries&siteid=0&co_partnerid=2&UsingSSL=0

I suppose the error I get when clicking on 'continue' on the page above is
linked to this issue. Could you please confirm?
*** Bug 109654 has been marked as a duplicate of this bug. ***
*** Bug 111865 has been marked as a duplicate of this bug. ***

Comment 26

17 years ago
When I ran into this problem I managed to submit my auction the hard way, by
manually typing in this in the URL bar while the review page was in the browser:

javascript:document.ListItemForSale.submit()

I figured this out from viewing the source of the page; it skips the bad code
and proceeds with the submission.

But somebody at Ebay really needs to do something about it.

Comment 27

17 years ago
I think this has been fixed?
(Reporter)

Comment 28

17 years ago
WFM 2001122103
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 29

17 years ago
WFM 2001112009

Looks like ebay finally came around

some1 close it

Comment 30

17 years ago
Verified
2002030908/WinXP
Status: RESOLVED → VERIFIED
No, this is still broken (tested with today's build)
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
*** Bug 140666 has been marked as a duplicate of this bug. ***

Comment 33

17 years ago
Confirm still existing problem with
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
(Assignee)

Comment 34

17 years ago
susie, can you help?

Comment 35

17 years ago
I successfully submitted upon clicking Continue using Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.0rc1) Gecko/20020424

Need more details to confirm if this is an ebay prob. please.

Comment 36

17 years ago
I'm sorry, I don't have anything to auction at the moment.  It looks like
someone created a reduced html example?
(Reporter)

Comment 37

17 years ago
WFM Win2k 2002042903
Previewing an auction works fine.   That's what I originally filed this bug
about.   Now if there's a problem with actually confirming the auction, I dunno.

Comment 38

17 years ago
In the spirit of fixing bugs, I tried submitted an item for sale, with no
problem at all. I also didn't have a problem cancelling it.

If you really are having a replicatable problem please include the platform and
build IDs and the specific problem you're having. Thanks.

Using Win2K Gecko/20020424

Comment 39

17 years ago
Confirmed. Still a problem with ebay.co.uk. The error is

Error: document.SelectorForm.StoreDeptId has no properties
Source File: http://cgi5.ebay.co.uk/aw-cgi/eBayISAPI.dll
Line: 73

This occurs when clicking on the continue button on the
bottom of the form in "step 3 or 5: pictures & details"
when trying to sell an item.

Using Linux/x86 Mozilla 0.9.9 (Build ID: 2002031312)

Comment 40

17 years ago
Also confirmed. Still a problem with www.ebay.de. Same as in comment #39 

From step 3 (pictures, price) to step 4 (payment, shipping) no reaction on
'next' ('Weiter' in german)

Error: document.SelectorForm.StoreDeptId has no properties
Source File: http://cgi5.ebay.de/aw-cgi/eBayISAPI.dll
Line: 75

Using Linux/x86, Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020503

ebay.de/ebay.uk are bug 132988 (The "national" sites are a separate team of
people to contact...)
(Reporter)

Comment 42

17 years ago
-> WFM
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
Email sent to my Ebay.de contact about this, will keep you updated

Comment 44

17 years ago
Well, I am still seeing this exact error message when I am in step 3 of "Sell 
Your Item 2" on ebay.com. I cannot select the "Your own Web hosting" tab in the 
Add Pictures area. Selecting this just throws this JS error. Could this bug be 
redefined to add this problem? I'd reopen, but I'm not sure if I should. It 
isn't totally related, but the error message is the same. This is a serious 
problem. I'm using 2002050308. I'll update and try again tonight, just in case 
it is fixed.
Reopening based on Wesley's comments (see also bug 140666 and comment 31).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 46

17 years ago
Wesley, please save and attach the html and js source which causes the error.
You can do a save web page complete and just zip it up.

Comment 47

17 years ago
Created attachment 82600 [details]
Page with Error

Here is the complete eBay page with the error. Clicking on the tab "Your own
Web hosting" does nothing.
The ebay.de people say that the San Jose group is in charge of all versions, so
we need to contact them.
Can someone who is seeing the isses give me details steps, leading from the main
page to the actual issue?  Ebay wants to know them before they check on it

Comment 50

17 years ago
Please see 140666 for how to replicate.
ok, on ebay.de the issue is:

if (!document.all && document.getElementById &&
(navigator.userAgent.indexOf("6.1") < 0) && (navigator.userAgent.indexOf("6.2")
< 0)) {isN6 = 1;}

So only netscape 6.1 and 6.2 will work.  They need a gecko sniff.
this should be fixed by next monday.
Target Milestone: --- → May

Comment 53

17 years ago
any new news on this?

Comment 54

17 years ago
Well, from what I can tell, it has been fixed. I received an email from eBay a
while ago announcing the "new" Sell Your Item 2.0, and it appears that it was
repaired then. I switched back and forth between the tabs and clicked Continue.
Everything I tried worked, and I didn't get any errors in the JS console. Unless
someone else is having problems, this should probably be marked as fixed.
Everyone who as seeing this, please retest.  
Whiteboard: [SYNTAX-HTML][FEP][MISSING-FORM] → [SYNTAX-HTML][FEP][MISSING-FORM][retest]
(Assignee)

Comment 56

17 years ago
->evang500
Keywords: evang500
if (!document.all && document.getElementById &&
(navigator.userAgent.indexOf("6.0") > -1)) {isN6 = 1;}

Anyone have any issues?  If not, bob, you can mark this fixed
I have issues.  There is no "6.0" in the default Mozilla useragent and will be
none in the NS7 useragent, most likely.  So that code is pretty unacceptable....

For that matter, does that even work with NS6.2?
(Assignee)

Comment 59

17 years ago
that sniffing is horrible. Susie, we need to talk to them about that.
isN6 is used for Netscape 6.0 only!  There was a bug in it which there are
circumventing.  Beforehand, and that was the causer of this entire issue, was
that they set isN6 to true if you did not have 6.1 or 6.2 in your Useragent.  I
got them to switch the logic to checking for 6.0 specifically.
marking fixed
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.