TEST-UNEXPECTED-FAIL | test-opening-messages.js | test-opening-messages.js::test_open_single_message_in_tab (and 3 more)

RESOLVED FIXED in Thunderbird 26.0

Status

Thunderbird
Folder and Message Lists
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: standard8, Assigned: hiro)

Tracking

({intermittent-failure})

Trunk
Thunderbird 26.0
x86
Linux
intermittent-failure

Thunderbird Tracking Flags

(thunderbird25+ fixed, thunderbird_esr2425+ fixed)

Details

Attachments

(1 attachment)

Seen since we switch from fedora to ubuntu test boxes, also seen on beta, so not just a trunk issue:

https://tbpl.mozilla.org/php/getParsedLog.php?id=27108466&tree=Thunderbird-Trunk#error0

Test Failure: messanges box height (644) not equal to the sum of displayDeck height (0) and message pane box wrapper height (611): '644' != '611'.
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/folder-display/test-opening-messages.js | test-opening-messages.js::test_open_single_message_in_tab
TEST-START | /builds/slave/test/build/mozmill/folder-display/test-opening-messages.js | test_open_multiple_messages_in_tabs
Test Failure: Thought we would find row 1 at 42,30 but we found -1
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/folder-display/test-opening-messages.js | test-opening-messages.js::test_open_multiple_messages_in_tabs
TEST-START | /builds/slave/test/build/mozmill/folder-display/test-opening-messages.js | test_open_message_in_new_window
Test Failure: Thought we would find row 1 at 42,30 but we found -1
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/folder-display/test-opening-messages.js | test-opening-messages.js::test_open_message_in_new_window
TEST-START | /builds/slave/test/build/mozmill/folder-display/test-opening-messages.js | test_open_message_in_existing_window
Test Failure: Thought we would find row 1 at 42,30 but we found -1
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/folder-display/test-opening-messages.js | test-opening-messages.js::test_open_message_in_existing_window
Summary: TEST-UNEXPECTED-FAIL | folder-display/test-opening-messages.js | test-opening-messages.js::test_open_single_message_in_tab (and 3 more) → TEST-UNEXPECTED-FAIL | test-opening-messages.js | test-opening-messages.js::test_open_single_message_in_tab (and 3 more)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 27

5 years ago
Created attachment 801521 [details] [diff] [review]
A workaround

On 32bit linux test platform, notification box seems to be showing on this test.

I am guessing that showing the notification box is caused by test-watch-ignore-thread.js.
Assignee: nobody → hiikezoe
Attachment #801521 - Flags: review?(mbanner)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 801521 [details] [diff] [review]
A workaround

Looks good. I'm willing to accept this to help the tree, though it might be nice in a separate bug if we investigated what the notification box is and why its still being shown.
Attachment #801521 - Flags: review?(mbanner) → review+
https://hg.mozilla.org/comm-central/rev/16d19b839245

Marking as tracking as I want to get these into branches to help with test failures (once they've cycled on trunk).
tracking-thunderbird24: --- → +
tracking-thunderbird25: --- → +
Target Milestone: --- → Thunderbird 26.0
Comment hidden (Treeherder Robot)
Comment on attachment 801521 [details] [diff] [review]
A workaround

[Triage Comment]
Looks good on trunk, taking onto aurora.
Attachment #801521 - Flags: approval-comm-aurora+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
tracking-thunderbird24: + → ---
tracking-thunderbird_esr24: --- → 25+
Comment on attachment 801521 [details] [diff] [review]
A workaround

[Triage Comment]
Lets get this on comm-esr24 as well, as we have the failures there.
Attachment #801521 - Flags: approval-comm-esr24+
You need to log in before you can comment on or make changes to this bug.