Closed Bug 910289 Opened 8 years ago Closed 8 years ago

Session state is not restored and Sync not working after updating Firefox

Categories

(Firefox for Android Graveyard :: General, defect)

26 Branch
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 26

People

(Reporter: u421692, Unassigned)

References

Details

Attachments

(1 file)

Attached file update_ff_sync_logs
Environment:
Device: LG Nexus 4
Build: Nightly 26.0a1 (2013-08-27) to Nightly 26.0a1 (2013-08-28)

Steps to reproduce:
1. Install Nightly 26.0a1 (2013-08-27)
2. Setup sync on the device and check to make sure sync is complete
3. Update Firefox from about:firefox page

Expected restult:
Firefox is updated, and synced data is preserved

Actual result:
Firefox is updated but synced data is lost, and user can not sync the data anymore, only after removing, then adding the account again.

Note: This may be an issue caused by changes to Session restore, since "requested profile directory missing: null" is displayed in logs.
I suspect bug 886925 as the cause. I am backing it out and requesting a respin of nightly.
I suspect this might be from the recent guest mode bustage we've had (bug 906030). i.e. we we're basically forcing the creation of a new profile named "guest" (not the normal guest profile), and now some nightly users are stuck on it.

I see a --guest argument in the logcat above.
(In reply to Wesley Johnston (:wesj) from comment #3)
> I suspect this might be from the recent guest mode bustage we've had (bug
> 906030). i.e. we we're basically forcing the creation of a new profile named
> "guest" (not the normal guest profile), and now some nightly users are stuck
> on it.
> 
> I see a --guest argument in the logcat above.

That --guest seems to have been caused by bug 886925 too. With the backout, the --guest part is gone.

Marking fixed by backout of bug 886925
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
This was fixed by the latest update for me, too.
No need to reconfigure sync account. 
Thx for the quick fix!
Verified as fixed on:
Device: LG Nexus 4
Build: Nightly 26.0a1 (2013-08-29) to Nightly 26.0a1 (2013-08-30)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.