Closed Bug 910389 Opened 6 years ago Closed 6 years ago

B2G xpcshell always exits with "ERROR - Return code: 256" regardless of success of failure

Categories

(Testing :: XPCShell Harness, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox24 wontfix, firefox25 wontfix, firefox26 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

RESOLVED FIXED
mozilla26
Tracking Status
firefox24 --- wontfix
firefox25 --- wontfix
firefox26 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: RyanVM, Assigned: mihneadb)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This causes the TBPL log parser to parse this as an error.

https://tbpl.mozilla.org/php/getParsedLog.php?id=27124931&tree=Mozilla-Central

b2g_emulator_vm mozilla-central opt test xpcshell on 2013-08-28 10:14:49 PDT for push 85c8745ac6c4
slave: tst-linux64-ec2-080

10:20:28     INFO -  INFO | Result summary:
10:20:28     INFO -  INFO | Passed: 40
10:20:28     INFO -  INFO | Failed: 0
10:20:28     INFO -  INFO | Todo: 0
10:20:28    ERROR - Return code: 256
10:20:28     INFO - TinderboxPrint: xpcshell<br/>40/0
10:20:28     INFO - # TBPL SUCCESS #
10:20:28     INFO - The xpcshell suite: xpcshell ran with return status: SUCCESS
I blame the intern.
Blocks: log-SnR
Assignee: nobody → mihneadb
Status: NEW → ASSIGNED
As Andrew pointed out, the problem is that we are doing int(True) which gives != 0.
Attachment #797326 - Flags: review?(jgriffin) → review+
https://hg.mozilla.org/mozilla-central/rev/05940765167e
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.