Explicitly store the application kind in webapps.json

RESOLVED DUPLICATE of bug 1042882

Status

RESOLVED DUPLICATE of bug 1042882
5 years ago
a year ago

People

(Reporter: fabrice, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Currently the webapps registry doesn't store whether an app is packaged, hosted or hosted+appcache. The situation is re-discovered with various heuristics and fragile.

We should just add that to as a "kind" field to the webapps.json registry storage, and use that in the call sites.
(Reporter)

Updated

5 years ago
Summary: Eplicitly store the application kind in webapps.json → Explicitly store the application kind in webapps.json
I'm going to work on this tomorrow. We could also have a different "kind" value for core apps, so that we don't have to do the check with the basePath.
Assignee: nobody → mcastelluccio
Status: NEW → ASSIGNED
Blocks: 911703
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1042882
Assignee: mar.castelluccio → nobody

Updated

a year ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.