Closed Bug 910604 Opened 9 years ago Closed 8 years ago

Facebook mobile site is totally missing main menu bar

Categories

(Web Compatibility :: Mobile, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jidanni, Unassigned)

References

()

Details

(Whiteboard: [country-all] )

Attachments

(1 file)

Attached image f.png
User Agent: Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0 Iceweasel/25.0a2 (Beta/Release)
Build ID: 20130823004003

Steps to reproduce:

Logged in to http://m.facebook.com/ with the latest versions of Firefox and Chromium,
using pristine 100% virgin profiles totally clean etc.


Actual results:

In Firefox the main menu bar is missing!


Expected results:

Please negotiate with the Facebook Corporation to ensure Firefox is not given the short shrift, if indeed this is not a Firefox bug.
The menu bar is missing with old Firefox 8 too. Maybe a TE bug.
So the mobile version of the world's #2 website is unusable in Firefox.
So the world's #2 website is unusable for Firefox mobile users.
So mobile Firefox users cannot use the world's #2 website.
So if this is a WONTFIX for Firefox and a WONTFIX for Facebook where am I supposed to file this bug?
Am I out of my mind? Can somebody give me a strait answer about where to send this?
Making chrome emulate firefox
http://www.howtogeek.com/113439/how-to-change-your-browsers-user-agent-without-installing-any-extensions/
shows this must be due to browser sniffing on the part of Facebook.

Now my experience is there is no way to get a word in edgewise to Facebook because of their 5000 employees are too busy as there are 1,000,000,000 users etc.

So I can only hope that somebody on Bugzilla who knows somebody at Facebook could take care of it.
Yeah, FB does some things with user agent sniffing, probably because it's the mobile version (and the variety of mobile browsers). Not sure if it's a bug.
Assignee: nobody → english-us
Component: Untriaged → English US
Product: Firefox → Tech Evangelism
Version: 25 Branch → Trunk
If you press the three bars circled at the left, you will realize all the functionality that is unaccessible  in Firefox vs. Chrome. Instead there are just vast white areas to the left and right of the screen.

You could imagine people would surely file a bug if even one menu item was missing. Well all 25 or so are missing so this is 25 times more serious. Anyway please just get an acknowledgment from the Facebook people
this this is inteded, and they have not simply confused Firefox's User-Agent string for some basic cellphone
 or rather PDA.
Assignee: english-us → nobody
Component: English US → Mobile
Whiteboard: [country-all]
Hi Dan,

Just to confirm, you're trying to visit m.facebook.com with Iceweasel? 

(Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0 Iceweasel/25.0a2 (Beta/Release))
Yes, now same problem with Iceweasel 29 or Aurora 29.
Facebook has a number of mobile sites they serve to different mobile browsers based on WURFL (and who knows what else) and device/browser capabilities. I don't know if it's worth approaching Facebook about receiving the tier1 touch version of the mobile site on Desktop.

One possible workaround would be to use touch.facebook.com, if for whatever reason you need to use their mobile site via a desktop browser.

Karl, what do you think?
I'm somewhat confused by this bug. As I understand it, Facebook's mobile site is not functioning on the Iceweasel desktop browser. If this is the case, I don't know that Facebook will prioritize a fix as this is likely an unsupported use case.

In terms of Facebook functioning in Firefox, we have been working directly with Facebook and their touch friendly mobile site does function well in Firefox mobile browsers. However, as Mike said, Facebook relies on WURFL for UA detection. If Iceweasel has a mobile variant and the UA is not recognized by WURFL, getting the UA into WURFL is the first step to resolving this issue.
I am not talking about any mobile variant. I am just saying that big firefox (iceweasel, aurora) looks bad on m.facebook.com. However touch.facebook.com looks good.

Let's just hope they can make both look good (and not one day break the second one too!)

So maybe they aren't processing the WURFL right.
I'm confused too. The fact that a version of the mobile site doesn't look good in the desktop version but look good in the mobile version of this same product is not a prioritized concern for the moment as in we are having bigger issues ;) to solve first as a community. 


Also "Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0 Iceweasel/25.0a2 (Beta/Release)"
As much as possible, I tried to stay away from more complicated User Agent strings. We have already plenty of breakage because of vendors adding stuff to UA. Facebook relies on UA detection, but I'm not sure we should spend time much time on this.

I understand how it can be frustrating Dan. You could try to contact them directly or file a bug at Facebook and if they say "no" it will be their business decision.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Flags: needinfo?(kdubost)
Resolution: --- → WONTFIX
(So why would someone browse m.facebook.com with big firefox? Well e.g.,
on underpowered EEEPC 702, vs. www.facebook.com, at least someone can
get something done.)

OK I will try to remember touch.facebook.com instead as a final workaround for me.

As far as little 1/billion Facebook user me being able to get a word in edgewise there, there is 1/billion chance. I would need to find a way to dress it up as a Developer Tools bug, as that is the only Facebook bug tracker open to me. The commoner (1/billion) bug form has, well, less chance of being effective as a communication means to Facebook. (Not to blame them, its a simple users/staff ratio problem.)
Well middle clicking the items in the touch.facebook.com notifications globe just leads back to broken m.facebook.com :-(
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.