[B2G][Helix][Setting][Wifi hotspot][shijinde]wifi hotspot and usb tethering can turn on together

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
P2
critical
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: lecky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E; Zune 4.7; Tablet PC 2.0)

Steps to reproduce:

1、turn on USB tethering
2、turn on WIFI hotspot(if failed, you can try again)



Actual results:

1、wifi hotspot and usb tethering can turn on together


Expected results:

1、USB tethering will turn off automatically
(Reporter)

Comment 1

5 years ago
1、if you reproduce the case, you can restart the phone, and see the wifi hotspot switch is turn, but follow the steps, I turn on the wifi hotspot switch after turn on the USB tethering, so I think the wifi hotspot should turn on
Severity: normal → critical
blocking-b2g: --- → hd?
Priority: -- → P1

Comment 2

5 years ago
Gecko will turn off either one if user is trying to enable both.
Vincent, can you take a look? Thanks.
Flags: needinfo?(vchang)
Wifi and usb hotspot should be able to turn on simultaneously, and this bug is fixed in Bug 787442 - Turn on wifi/usb tethering simultaneously in mozilla-central.
Flags: needinfo?(vchang)
(Reporter)

Comment 4

5 years ago
 leo.bugzilla.gecko@gmail.com 2013-07-18 10:55:46 CST 
 (In reply to Alex Keybl [:akeybl] from comment #13)

Please provide a justification for blocking, as this
> is not regression in 1.1 and isn't milestoned.

We decided not appling this patch.
Thanks


---------

Hi, mozilla don't apply that patch, so I want to kown when do you apply to helix?

Thanks
(Reporter)

Comment 5

5 years ago
Hi, what is the result about this problem? 

if you can't resolve in v1.1, please give me the information in the bug.

or if you can resolve in v1.1, also please give me the plan.

Thanks

Comment 6

5 years ago
(In reply to Vincent Chang[:vchang] from comment #3)
> Wifi and usb hotspot should be able to turn on simultaneously, and this bug
> is fixed in Bug 787442 - Turn on wifi/usb tethering simultaneously in
> mozilla-central.

I can reproduce this on latest partner build (9/10). However, it seems the behavior is valid per Gecko design on m-c, so if you decide to take m-c build(v1.2), then it's not a bug.
(Reporter)

Comment 7

5 years ago
Ok, I will give that result to my team.

Thanks
(Reporter)

Comment 8

5 years ago
Hi, Evelyn,

    About this bug, did you have sent this information to operator? we had decided will not upgrade to V1.2.

Thanks
(Reporter)

Updated

5 years ago
Flags: needinfo?(wchang)
Flags: needinfo?(brg)

Updated

5 years ago
Flags: needinfo?(wchang)

Updated

5 years ago
blocking-b2g: hd? → ---
Not a blocker for TEF. As a general rule, non-critical bugs for 1.1HD that can be also reproduced in 1.1 are not blockers for us. This can be solved by the partner on their own branch or we can wait for an 1.2 OTA update.
Flags: needinfo?(brg)
(Reporter)

Updated

4 years ago
Priority: P1 → P2
(Reporter)

Comment 10

4 years ago
Hi, Wayne, 

   Can you give me the patch, and I will merge to my branch.

Thanks
Flags: needinfo?(wchang)
bug 787442
Flags: needinfo?(wchang)
(Reporter)

Comment 12

4 years ago
Hi, Daniel Coloma

    This bug We can't merge to helix, We try to merge, but there are so many differrent codes. 
So this one we will wait 1.2.

Thanks

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.