[B2G][Helix][Character][zhaotao]The character of OS is error.

RESOLVED FIXED

Status

Mozilla Localizations
es-ES / Spanish
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: lecky, Assigned: Inma Barrios)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 797111 [details]
Issue List Colombia .xlsx

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:

Set the language to Spanish, then please see the attachment for issue details.



Expected results:

Please see the attachment for issue details.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?
Priority: -- → P2
(Reporter)

Updated

5 years ago
Severity: normal → blocker
(Reporter)

Comment 1

5 years ago
hi,there are also some brazil character error,please check the attachment file.
(Reporter)

Comment 2

5 years ago
Created attachment 798713 [details]
Firefox Project Character Check_brazil.xlsx
(Reporter)

Comment 3

5 years ago
gaia:      134356dc21d0627455f8bc536b140a18f39e20e9
gecko:     2e2b4393b0581ef72a1cb70fc5f002cd82a9302a
gonk-misc: ca9192d7ef6037016d4723647d86b72f7a410633
(Reporter)

Comment 4

5 years ago
Please only check the red font in Check_brazil.xlsx
Hi Axel,

Can you check this bug? Apparently as in the attached files we have various translation errors/missing.

Thanks
Flags: needinfo?(l10n)
Lecky, what is the branch you are testing? v1-train? master?

Thanks
Flags: needinfo?(l10n) → needinfo?(lecky.wanglei)
Lecky, I see that this is the 1.1HD branch.

Can you check what is the commit of the "Spanish" translation in your build? I think you need to ask your Releng to check that https://hg.mozilla.org/gaia-l10n/es/ has always the latest commit.

Comment 8

5 years ago
We should split this into an 'es' and an 'pt-BR' bug. I'll clone this to get a pt-BR one, and then move this bug to Spanish.

Lecky, for future iterations, it'd be great to have the proposed corrections.

Willy, https://github.com/mozilla-b2g/gaia/commit/134356dc21d0627455f8bc536b140a18f39e20e9 is 24 days old. If they used the latest /es/, the differences since then would be 
https://l10n.mozilla.org/source/diff/?from=65bdc025e6ba&to=61cfa8f177ae&repo=gaia-l10n%2Fes

Updated

5 years ago
Blocks: 912947

Comment 9

5 years ago
Comment on attachment 798713 [details]
Firefox Project Character Check_brazil.xlsx

Marking the Brazil one obsolete as it's now in the pt-BR bug.
Attachment #798713 - Attachment is obsolete: true

Updated

5 years ago
Assignee: nobody → rpmdisguise-otros
Component: Gaia → es-ES / Spanish
Product: Boot2Gecko → Mozilla Localizations
(In reply to Axel Hecht [:Pike] from comment #8)
> We should split this into an 'es' and an 'pt-BR' bug. I'll clone this to get
> a pt-BR one, and then move this bug to Spanish.
> 
> Lecky, for future iterations, it'd be great to have the proposed corrections.
> 
> Willy,
> https://github.com/mozilla-b2g/gaia/commit/
> 134356dc21d0627455f8bc536b140a18f39e20e9 is 24 days old. If they used the
> latest /es/, the differences since then would be 
> https://l10n.mozilla.org/source/diff/
> ?from=65bdc025e6ba&to=61cfa8f177ae&repo=gaia-l10n%2Fes

Yeah. That means that they are not getting latest commits from our repository.

Still needinfo? on Lecky.
IIUC, part of the errors are actually translations not being taken from the repository, which account for most of the reported errors.

For the reamining, we (Guillermo, Inma and myself) will review it once the untranslated strings issue is fixed, but I must say that many of the corrections proposed are either a style matter that may vary from country to country (like "Soy de prepago" vs. "Soy prepago"), or are simply invalid ("monitorear" is not a valid Spanish word, even if it is used as an imported form from English; the right word is "monitorizar").
(Assignee)

Comment 12

5 years ago
Hi awesome people,

I just checked out the attached issue list, and there are some suggestions that may help us to enhance the Spanish translation making it more neutral:

*Plug in: "conectar", rather than "enchufar";
*Headset: "manos libres", rather than "auriculares";
*Brightness: "brillo", rather than "luminosidad".

Please let me know what you think. Thanks,
(In reply to inma_610 from comment #12)
> Hi awesome people,
> 
> I just checked out the attached issue list, and there are some suggestions
> that may help us to enhance the Spanish translation making it more neutral:
> 
> *Plug in: "conectar", rather than "enchufar";
> *Headset: "manos libres", rather than "auriculares";
> *Brightness: "brillo", rather than "luminosidad".
> 
> Please let me know what you think. Thanks,

+1
(In reply to inma_610 from comment #12)
> Hi awesome people,
> 
> I just checked out the attached issue list, and there are some suggestions
> that may help us to enhance the Spanish translation making it more neutral:
> 
> *Plug in: "conectar", rather than "enchufar";

OK.

> *Headset: "manos libres", rather than "auriculares";


I'm in favor of keeping "auriculares" (or an equivalent word that may sound more neutral). You don't need to plugin specifically headsets for mobile phones, that feature a micro, to listen to FM radio; conventional headsets will work to act as an antenna. The original string says just "headset".


> *Brightness: "brillo", rather than "luminosidad".


OK.


As we're reviewing the suggestions, in row 7 the issue is "A Camera le gustaría conocer su ubicación." and it is proposed that "A la cámara le gustaría conocer su ubicación" be displayed instead. I think this is a generic message to inform the user some application is requesting privileges and thus "Camera" is not a literal, but a variable. If so, while we must make sure the localized name is displayed ("Cámara"), we can't add "la" because other application names may have male gender. We could instead change the string to "A la aplicación &appName; le gustaría conocer su ubicación".

In row 26, it is reported that the string "Datos de itinerancia" is wrong. I can't find that exact string; instead, we have "Datos en itinerancia", which is as correct as "Itinerancia de datos" (in Android, the only similar string I've seen is "Mensajes en itinerancia", which follows the style of the current translation reported).

In row 30, it is reported that "Autoajustar" is wrong. Actually, it is a valid and usual word in Spanish, but anyway it seems that we no longer have that in Gaia L10n. Instead, we have "Ajustar auto.".

Updated

5 years ago
Duplicate of this bug: 911688
(Reporter)

Comment 16

5 years ago
hi,Guillermo,

things get much better after we update gaia-l10n from master,

but we are still concerning that if the language resources are consistent between master and V1.1HD branch?

We are still verifying,i will update the bug if we find new problem.
Flags: needinfo?(lecky.wanglei)
(Reporter)

Comment 17

5 years ago
Hi Axel,
On v1.1 HD, we use the latest gaia-l10n(e6f0277c87336de7e741b7c92d69aa67479f49c6), and find some espanol strings are not our expected. please refer the attached file(The strings in espanol that are not our expected strings.xlsx).

Can these strings be modified to our expected?

Thanks.
Flags: needinfo?(l10n)
(Reporter)

Comment 18

5 years ago
Created attachment 808963 [details]
The strings in espanol that are not our expected strings.xlsx

Updated

5 years ago
Flags: needinfo?(l10n)

Comment 19

5 years ago
Comment on attachment 808963 [details]
The strings in espanol that are not our expected strings.xlsx

Inma, can you have a look at these?
Attachment #808963 - Flags: review?(inma.barrios)
(In reply to Axel Hecht [:Pike] from comment #19)
> Comment on attachment 808963 [details]
> The strings in espanol that are not our expected strings.xlsx
> 
> Inma, can you have a look at these?

I'm taking a look to it, too.
Ricardo, Inma and Guillermo will review carefully the excel file. They are the experts and they know which suggestions can be addressed. They will discard those out of our Spanish understanding like issues number 9 and 34 in your document.

The l10n repository is shared by all the devices porfolio and the length of the strings is adjusted to the size of different devices.
Created attachment 809238 [details]
Gaia.xlsx

The attachment 808963 [details] with an additional column with my comments. Please note that these are only my opinions, not the definitive answer, as Inma and Guillermo are the actual L10n owners of Gaia for Spanish.
(Assignee)

Comment 23

5 years ago
Hi,

First of all, I'd like to thank @lecky for his complete Gaia QA test. I just check out @Ricardo's comments, side notes and suggestion, and totally agree on them. Most of lecky's l10n issues are not really so, and the current strings are OK. 

For instance, there is no error in using "Sinc. amigos" rather than "Sincronizar amigos", it's just a way to make the string shorter, and this translation decision (and the like) has been made after long discussions in multiple bugs to make sure not only Firefox OS UI was properly translated, but also displayed nicely. 

Similarly, some proposals are definitely wrong, like suggesting changing "Guardar imagen" (which is actually OK) to "Guardad imagen" (which a CTA, and doesn't properly fit in this context). Additionally, UI items have a different capitalization in Spanish, and only initial letters should be used in uppercase. Spanish language institutions and organizations (such as RAE* or Fundeu**) suggest avoiding the use of unnecessary anglicisms, like "roaming", and also propose using "wifi", not "Wi-Fi". The Spanish localization team follows strictly these recommendations.

Nevertheless, we'll apply your valid suggestions to the upcoming 1.2 to make it better. 

Thank you all for your help.

* rae.es
** fundeu.es
(Assignee)

Updated

5 years ago
Attachment #808963 - Flags: review?(inma.barrios) → review-
(Reporter)

Updated

5 years ago
blocking-b2g: hd? → ---
(Reporter)

Updated

5 years ago
Severity: blocker → normal
(Reporter)

Comment 24

5 years ago
Dear Beatriz Rodriguez,

Could you have a look at the attched file "The strings in espanol that are not our expected strings.xlsx"?
If these strings are not translated to our expected strings, Do you accept it?

Thanks.
Flags: needinfo?(brg)
(In reply to lecky from comment #24)
> Dear Beatriz Rodriguez,
> 
> Could you have a look at the attched file "The strings in espanol that are
> not our expected strings.xlsx"?
> If these strings are not translated to our expected strings, Do you accept
> it?
> 
> Thanks.
Please read comment 21 already ansered your question.
Flags: needinfo?(brg)
(Reporter)

Comment 26

5 years ago
Dear Inma,

I use the latest gaia-l10n resource and find some strings are not translate to espanol, as following:
(1),Open settings app, settings-->Phone lock-->Passcode lock-->Required Passcode-->After 2 minutes and After 5 minutes.
  ---"After 2 minutes" and "After 5 minutes" is translate to "Tras 2 minutos" and "Despues de 5 minutos", Does these two strings can be translated to "Tras 2 minutos" and "Tras 5 minutos"?

(2),In Setting->Cellular & Data->Network operator->Automatic selection, set the "Automatic selection" to off, and register to the network by handwork, the subhead of the "Automatic selection" is "manual", please refer the attched file "manual-error.png". The string "manual" is not translated.

(3), Open the clock app, in the sound area, Only "No Sound" translate, the others are not translated, please refer the attached file "clock-error.png".

(4), In the ftu, on the Data & Time UI, if we choose the America time, the subhead of the "Time zone" like "UTC-10:00 America/Adak", the string "America" is not translated.

(4), In the ftu, on the Geolocation UI, Open "More about your privacy -->everything.me", the submenu "about","jobs", "blog" and "contact" are not translated.

Could you hava a look at these and to see if these are the bugs or not? If these are the bugs, is there the plan to solve these?

Thanks.
Flags: needinfo?(inma.barrios)
(Reporter)

Comment 27

5 years ago
Created attachment 821642 [details]
manual-error.png
(Reporter)

Comment 28

5 years ago
Created attachment 821643 [details]
clock-error.png
(Assignee)

Comment 29

5 years ago
(In reply to lecky from comment #26)
Dear Lecky,

I'll answer in line:

> 
> I use the latest gaia-l10n resource and find some strings are not translate
> to espanol, as following:
> (1),Open settings app, settings-->Phone lock-->Passcode lock-->Required
> Passcode-->After 2 minutes and After 5 minutes.
>   ---"After 2 minutes" and "After 5 minutes" is translate to "Tras 2
> minutos" and "Despues de 5 minutos", Does these two strings can be
> translated to "Tras 2 minutos" and "Tras 5 minutos"?

Thanks for pointing this out. Those inconsistencies have been fixed in v1.2 - all strings containing "After" + x measure of time have been translated as you suggested above.
> 
> (2),In Setting->Cellular & Data->Network operator->Automatic selection, set
> the "Automatic selection" to off, and register to the network by handwork,
> the subhead of the "Automatic selection" is "manual", please refer the
> attched file "manual-error.png". The string "manual" is not translated.

Well, in fact "manual" is exactly the same word both in English and Spanish :)
> 
> (3), Open the clock app, in the sound area, Only "No Sound" translate, the
> others are not translated, please refer the attached file "clock-error.png".

Yep, the Spanish team agreed on not translating the names of ring tones.

> 
> (4), In the ftu, on the Data & Time UI, if we choose the America time, the
> subhead of the "Time zone" like "UTC-10:00 America/Adak", the string
> "America" is not translated.

Actually it is translated - América. Please note the accent on the vowel "é".
> 
> (4), In the ftu, on the Geolocation UI, Open "More about your privacy
> -->everything.me", the submenu "about","jobs", "blog" and "contact" are not
> translated.
> 
Could you add a screenshot of that please?

Thanks,
Flags: needinfo?(inma.barrios)
(Reporter)

Comment 30

5 years ago
(In reply to inma_610 from comment #29)

Dear Inma,
Thanks for reply.

> 
> (4), In the ftu, on the Data &
> Time UI, if we choose the America time, the
> subhead of the "Time zone"
> like "UTC-10:00 America/Adak", the string
> "America" is not translated.
> Actually it is translated - América. Please note the accent on the vowel
> "é".

There are two "America" on the UI, one is translated, but the other is not translated, please refer the attached file "America-error-in-espanal.png".


> (4), In the ftu, on the Geolocation UI, Open "More about your
> privacy
> -->everything.me", the submenu "about","jobs", "blog" and
> "contact" are not
> translated.
> 
Could you add a screenshot of that
> please?

Please refer the attached file "everything-menu-error-in-espanal.png".

Thanks,
Flags: needinfo?(inma.barrios)
(Reporter)

Comment 31

5 years ago
Created attachment 822099 [details]
America-error-in-espanal.png
(Reporter)

Comment 32

5 years ago
Created attachment 822100 [details]
everything-menu-error-in-espanal.png

Comment 33

5 years ago
Same here as in pt-BR's bug 912947, timezone names are not localized yet. Also, the localization of the everything.me webpage is independent of the work that mozilla does.
Flags: needinfo?(inma.barrios)
Reviewing this bug, I'd say that valid concerns were addressed and the remaining two in comment #30 are out of our reach, as Axel confirms in comment #33, so assigning to Inma and marking it resolved fixed.
Assignee: rpmdisguise-otros → inma.barrios
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.