CSS2 :before and :after content grow on hover inside an <a>

VERIFIED DUPLICATE of bug 69398

Status

()

VERIFIED DUPLICATE of bug 69398
17 years ago
17 years ago

People

(Reporter: l.fasolo, Assigned: pierre)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Connect to 

http://www.ilsole24ore.com/quotidiano/

Move the mouse in the navigation bar under the title
and the banner; the navigation banner will enlarge itself.
(for example, try to click on "english edition": "english" and
"edition" will move).

tested with Mozilla 0.9.2 and with nightly build 2001071408
I see the problem with win98 Mozilla 2001071604 trunk
A stylesheet linked to by the page contains
    br:before { content: "\a";}        , which makes <br> tags inside <a></a>
churn out linebreaks on contact with the mouse pointer.
I made a bit more generic testcase, also demonstrating a similar problem with an
:after rule.
Assignee: asa → pierre
Status: UNCONFIRMED → NEW
Component: Browser-General → Style System
Ever confirmed: true
QA Contact: doronr → ian
Summary: Strange behavior of a site → CSS2 :before and :after content grow on hover inside an <a>
Duplicate of "{label,hr,br}:after {content: ":"}   repeats creation of : with
mouse movement"

*** This bug has been marked as a duplicate of 69398 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.